keyboard and mouse stop working on start-up

  buttsmacca 16:12 18 Nov 2007
Locked

Hi,

I have an Acer travelmate 4222 with XP (SP2). I had to re-install "Launch Manager" as it started to play up. Downloaded version 1.02.1e from their site. After installing, i was prompted to re-start the computer. I got to the log in page, mouse pad was still working, but as soon as I began to type in password, keyboard and mousepad died. no messages, nothing. it was as if windows simply stopped recognising they existed. I tried starting up in safe mode, but even then, as soon as windows kicks in, the keyboard and mouse fail without any messages. Does anyone have any advice for me at all? Acer support is completely useless, i don't want to even bother with them. If i told them my battery strngth was going down, they would suggest that I run a complete recovery, no matter what the problem is.
Please, if anyone has any advice, please help!
Thanks!

  Fruit Bat /\0/\ 16:46 18 Nov 2007

Sounds like the windows drivers for the keyboard and mouse are missing.

Boot into safe mode (F8)hopefully keyboard will work in safe mode and reload the drivers.

  avesnes1 20:54 18 Nov 2007

I had something similar using Vista although theproblem was intermittant. Before trying the reloading drivers route, I ran ccleaner and it may have been just coincidence but it seemed to have cleared the freeze problem.

  buttsmacca 21:47 18 Nov 2007

PROBLEM SOLVED:

OK, so the first thing I obviously tried was to connect an external keyboard via USB, but because I wasn't logged in, windows didn't recognise it.

I was able to log in as a "guest" user since I didn't have any password requirements for that. From there, using the still functioning mousepad (works as long as I didn't press any keys on keyboard), I went to device manager and found there was a conflict with my keyboard, error code 19 i think it was. since i was logged in as "guest" i didn't have any administrator rights to fix it there., I then connected the external keyboard which was accepted by windows, then switched users (i can now log into my usual profile since I can type my password using the external keyboard!).
From there, I went to device manager, deleted the conflicting keyboard, and let windows search and add new hardware. IT WORKED!

Thing to remember, MAKE SURE YOU HAVE ATLEAST 1 PROFILE ON YOUR LAPTOP WHICH DOES NOT REQUIRE A PASSWORD TO LOG IN!

  Jones6340 18:57 28 Jan 2008

I have a Averatec 6200 ser, AMD Athlon XP-M 2400, 512 MB DDR, 60 GB HD, which i purchased about 4 years ago. I have just upgraded to Windows Vista Premium and now cant get the touchpad or keyboard to work. I went onto the Averatec website and it appears the new downloads are not ready for the 6200 series. So really there is a conflict with somewhere. Can anyone help as this is doing my head in

  buttsmacca 06:57 29 Jan 2008

Was Vista unable to find the right driver for your system straight off? Perhaps you can try a generic keyboard and mouse driver?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone