Keyboard commands not recognized on PC wakening

  pmay805 02:44 26 Jun 2014
Locked

I have an HP desktop with Windows 7. Sometimes when my PC is sleeping I press the escape button and the computer wakes up but any key I press after that like typing my password in, or if take the password requirement away, no key for letters or numbers will work either on the browser, excel, or word. The mouse does continue to work. I have to restart the computer by engaging the power button to get the keyboard to work again. Anyone have any ideas on what the problem could be?

  wee eddie 07:49 26 Jun 2014

Are you using an USB Keyboard or a PS2 one?

  pmay805 16:04 13 Jul 2014

I have one kybd connected to usb port and one connected to ps/2. Sometime one will work and the other one won't. They alternate. Sometimes they both won't work and I have to reboot. Now the mouse won't work on occasion as well & I have to reboot. Any ideas??

  Woolwell 18:41 13 Jul 2014

They are not connected at the same time are they?

  pmay805 03:48 14 Jul 2014

Yes. I am keying this reply from both keyboards.

  mole1944 05:19 14 Jul 2014

I from time to time find my Usb keyboard fails to work,i just unplug the keyboard plug it straight back in and back to normal for a few months.I have no idea why it happens,perhaps others in this forum might have a clue but it remains a mystery to me.

  Woolwell 07:33 14 Jul 2014

I fail to understand why anyone would want 2 keyboards plugged in at the same time. This could be the cause of your snag. Try with one.

  Woolwell 10:06 14 Jul 2014

I'm not sure that this thread isn't a wind up.

  pmay805 04:20 02 Aug 2014

Well, I think my PC keybd and mouse problem may be gone. Initially, the keybd would not operate on wakening. After a month or so, the mouse started doing the same thing. Only a reboot would bring them to life. A week or so later, even the reboot would take 3 tries before they came to life. During all this time I had tried other keybds and mice, run anti-malware software, registry cleaners, uninstalled and reinstalled all drivers and USB ports, run memory and BIOS diagnostics, replaced the CMOS battery, and all to no avail. Finally, I pulled by hard drive out of the tower and placed it in another. The problem seems to be resolved since I’ve had no incidents today. I’m assuming the problem was in the motherboard. Since it progressively got worse over time I would guess it was a hardware problem on the motherboard as opposed to firmware but I’m no tech expert. I’m just hoping I’m done with this problem.

Anyone out there know how expensive a motherboard is?

Thanks for everyone’s input. :)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

Photoshop CC 2018 released with new Curvature Pen and better brush tools

Camera tips to take better iPhone photos

Les meilleures applications de covoiturage 2017