K: is not accessible ??

  malwarehater 12:06 17 Jul 2006
Locked

After an unexpected shutdown by Windows i can't access my external drive anymore....i get the following message even if i restart my pc.

"K:\ is not accessible.
The file or directory is corrupted and unreadable"

I have tried using another usb port but it makes no difference........If i unplug the drive then plug it back in for example,Windows does the usual- scans the drive, but nothing....and the same message appears.

Anyone have any idea how i can re-access this drive??

Thanks Guys

  ArrGee 12:19 17 Jul 2006

I had a similar problem a while ago. First things first. If your hard-drive is in a caddy, unplug it then plug it back in. Have you tried using the drive on a different machine?

  malwarehater 12:23 17 Jul 2006

hi ArrGee.

Yes ive tried unplugging it and then plugging it back in.......it makes no difference.....I'll now try it in another pc and report back.

  malwarehater 12:56 17 Jul 2006

Tried it in another pc.....same message appears.

Does this really mean the drive is corrupted? is so, in which way is it corrupted? and is there a way to fix it, or retrieve my data from it?

It's a Maxtor Diamondplus Max 120, so it's got a hell of a lot of data on it.

Thanks Guys

  ArrGee 13:11 17 Jul 2006

Try the Maxtor diagnostics click here

  johnnyrocker 13:14 17 Jul 2006

is it a caddy with a hard drive fitted into it? if so check it is still plugged in securely inside caddy.



johnny.

  malwarehater 15:13 17 Jul 2006

i think i have cured it.

I tried it in (it's caddy) in my old pc....same thing and same message appeared.

Now i dont know if this is related to the problem but my MAIN pc has 2 SATA drives,and the ext K: drive (IDE hard drive btw) is running via a usb2 port on that pc.....when it got corrupted (after a sudden shutdown) i kept getting the message as in the top post.

Trying to connect it(in it's caddy)to to a usb port on my old pc (which is fully IDE).....made no difference.

I then took it out of it's ext caddy and plugged it into my old (IDE)pc, and started it up.....the blue screen appeared and said that K: needed to be checked for errors....which it did- it fixed loads of errors, then Windows promptly loaded up and i could access the drive, and ALL files and folders.........so the drive MUST be ok.

I then took it out of the old pc....refitted it into the ext caddy and plugged it back into the MAIN(sata)pc and again, it seems to be working fine now....So could it be that the circuitry on the caddy is breaking down intermittently or maybe it's not too compatible with SATA drives in the system,as the drive itself now seems fine?

  malwarehater 15:17 17 Jul 2006

Just out of interest....i have also had a similar prob(tho not quite as bad) with the ext hd after running CrapCleaner.......it must be deleting files that windows uses to access this ext drive.

  ArrGee 10:56 18 Jul 2006

Be careful with CCleaner. It's a great application but must be handled with care.

You seem to have gone through precisely the same predicament as myself with your external drive. Now that you have access to it, I would strongly suggest that you move your files off of it and format using Maxtor formatting s-ware. Then re-load your data onto the drive.

  malwarehater 18:54 19 Jul 2006

Thanks ArrGee.

I'm in the process of doing that now.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Les meilleures tablettes 2017