Just getting my head around validation....

  ade.h 22:20 26 Mar 2006
Locked

...and I have a couple of quick questions. As those of you who use NOF will know, it puts out 4.01 Transitional code, or claims to (ha!), but I typically get about 25 errors - mostly similar - on an average page.

The validator on the W3 site has given me, among other bits:

Line 9 column 7: required attribute "TYPE" not specified.

script>

The attribute given above is required for an element that you've used, but you have omitted it. For instance, in most HTML and XHTML document types the "type" attribute is required on the "script" element and the "alt" attribute is required for the "img" element.

Typical values for type are type="text/css" for style> and type="text/javascript" for script>.

How do I make sure that I've identified the right line - script> occurs on lines 8 and 12, so I'm guessing there must be some lines that should not be counted?

And how can I make sure that I use the right tag? I assume it has to be "text/css", but I'm not sure.

(I've only begun teaching myself html this weekend!)

  ade.h 22:22 26 Mar 2006

Is there a way of stopping the "less-than" symbol from dropping out of postings by the way?

  ade.h 15:57 27 Mar 2006

Thanks John. I'll give that a go. Most of the errors fall into a small number of types - things like undefined tags, etc.

I'll leave this open for now, as I will probably have to add one or two related questions shortly.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone