Jumping, uncontrollable mouse

  guesswho2 18:32 30 Jan 2009
Locked

This seems to have happened as a result of a 248MB Net Framework download.
I've tried uninstalling the mouse driver in Device Manager to no avail.
Suggestions welcomed!

  Technotiger 18:34 30 Jan 2009

What type of mouse? If it has a ball underneath, then it could simply need cleaning.

  guesswho2 20:53 30 Jan 2009

No, it's more fundamental than that Technotiger. In any case it's an optical mouse. I'm sure it must be connected with that huge Net Framework download because everything was fine beforehand. Unfortunately I stupidly forgot to make a System Restore point so I can't think of a foolproof way of getting back to square 1. I don't I dare try to uninstall from Add/Remove.
Previously this afternoon I had just fitted an ethernet card in a PCI slot after the onboard job had failed. Then I managed to reinstall the HG520b router and was feeling pleased with myself - until this happened!

  Technotiger 20:56 30 Jan 2009

Have you tried another mouse? Or, as long as you do not have System Restore disabled, you should be able to do a Restore.

  Technotiger 20:57 30 Jan 2009

OR, go to the Mouse in Devices again, and click on Update driver.

  guesswho2 21:13 30 Jan 2009

Can't do a Restore because that dratted download was too close in time to the reinstallation of the router - I don't want to go through all that again. No mouse driver update available.

  guesswho2 21:35 30 Jan 2009

Not sure what I've done, but it seems OK now!

  Technotiger 21:40 30 Jan 2009

Fair enough, lets hope it stays that way then.

Cheers.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

Illustrator Sylvain Tegroeg created thousands of intricate line drawings for the mobile game…

Best iPad buying guide 2017

Comment télécharger une application indisponible en France ?