Javascript not enabled?

  Honrose 12:32 29 Jun 2009

Hi,I've just accessed a learning site, and it says I need Javascript enabled - I thought it was! I've searched endless (aimlessly?) round my Help section and the internet and can't fix the damn thing?

Any boffins out there who can help?

Many thanks

  johndrew 12:39 29 Jun 2009

If you are running Firefox with NoScript as an AddOn then you need to click on the icon at the lower left and `Allow` the site. Or go to `Tools/Options` and make certain the `Enable Java` box is ticked then click `OK`.

  T I M B O 12:39 29 Jun 2009

I have just looked in the control panel on xp and found java there. Click on that jave>>then java tab>>click View>>on the right of that window there are or could be boxes, make sure there are check marks in there. I assume this might be the case for Vista also.

  OTT_Buzzard 12:41 29 Jun 2009

If none of the above work click here

  Honrose 13:23 29 Jun 2009

Hi guys and thanks.

I'm running Windows Explorer 8 - went to the I/n Options Security and enabled active scripting, but still not joy! Never had this problem before, driving me potty!

Would it be an idea to delete Java and download it again? Can't think of what else to do - except buy a new PC lol!


  brundle 13:28 29 Jun 2009

Javascript and Java are two different things. Java itself is not the problem. You can try adding the site to your Trusted Sites list in IE. Check your security software/firewall is not blocking elements of the site too.

  brundle 13:30 29 Jun 2009

click here

Test Javascript; click here

  Honrose 13:59 29 Jun 2009


Thanks for that - ran it thru the diagnostic and it passed :(

so presumably the prob is with the webpage itself? The one I'm accessing, I mean.

Thanks for all the tips - my reputation as a Silver Surfer is in jeopardy here! ;)


  brundle 14:19 29 Jun 2009

Can you link to the page itself? Have you tried another browser? If you're using Vista with IE I've seen some strange behaviour when user profile permissions have become corrupted in some way - some content can only be viewed when IE is run as Administrator, which disables Protected Mode. Disabling UAC has the same effect. Not recommended practice.

  johndrew 16:48 29 Jun 2009

It could be worthwhile downloading Firefox and trying the page in that.

  Honrose 21:59 29 Jun 2009

Hi, and thanks for all the advice.

I tried the webpage in Opera then in Firefox and got exactly the same result. I've contacted the Webmaster and explained it to them - hoping they come back with a reason/solution soon.

Thanks for the help, I'll post again if/when I get it resolved.


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Les meilleures tablettes 2017