Java Problem

  TRICKY 22:49 20 Aug 2005

Like others I saw that I had a lot of Java taking up memory. I followed the instructions to uninstall JSE Runtime Environment 5.0 Update 4. Seems quite simple....
Add/Remove Programs
Highlight JSE Runtime Environment 5.0 Update 4
Click Remove

Simple! Except It then gives me the following message:
"You already have this version of JRE installed. Please remove through your add/remove program utility before reinstalling"
Then says
"Fatal error during installation"

Not bad, seeing as i was removing and not installing?

Its still there in the Add or Remove Programs box?

I have also looked in Control Panel, and clicked the Jave Icon. This gives me an error saying:
"The system cannot find the registry key specified: HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime ENironment\1.5.0_03"

I have tried downloading the Java Runtime Environmet 5.0 Update 4 again. It will not let me install as it says its already there.

Totally confused now. Anyone know how to get out of this one.

hope I have explained it properly.


  QuickHare 23:33 20 Aug 2005

Most programs and applications use an installation program to also uninstall the same programs. Very few have a seperate uninstaller to the installer.

What you're getting is due to the fact that you're running the installer to uninstall, which is perfectly natural in most cases. But this uninstaller/installer detects the version installed and stops when it finds the same (or better) is installed already.

Hopefully another member can provide steps to help you further, but I'd suggest taking a look at the Sun website to find your version, and to see if there are any other uninstallation instructions.

  hugh-265156 00:43 21 Aug 2005
  ashdav 01:26 21 Aug 2005

Go to program files and delete the Java folder. Then run Ccleaner click here and run issues. Delete anything found. Repeat issues until nothing is found.

  TRICKY 09:02 23 Aug 2005


Thanks, tried your suggestion. Deleted everything I could find with Java, Sun, Jre etc. Also deleted from registry. Still says its loaded.


Thanks for the little utility. Must admit I like it. Done as suggested, cleaned up lots, resolved quite a few issues. But as I have said to huggyg71, it still says JRE 5 is still loaded. Wont let me reload, also still have a stray entry on my Add/Remove with no buttons to remove anyfurther.


I have reloaded 1.4.2 in the meantime. But cannot go up to 5.

  TRICKY 09:17 23 Aug 2005

In todays day and age. Has someone not come up with a simple utility that will completely remove all traces of Java? Wish I could do it.

  anchor 09:34 23 Aug 2005

Personally, I stick with Microsoft Virtual machine. Still available from various sites, including:

click here

Works fine with WinXP-SP2. I did try Sun Java and found the MS version smaller, and even worked better on some sites.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best Black Friday Deals 2017

How modern book design was influenced by illustrated manuscripts

Best Black Friday Apple Deals 2017

Les meilleurs logiciels de montage vidéo gratuits (en 2017)