Java crashing browser

  f1charlie 12:19 29 Oct 2009

I noticed that Java applets were not displaying when I visited a website. I checked the test on the Java website and that didn't work. Java said that my version was out of date. It said I had version 6 update 15 and should update to 16. I did that and tried the test again -still didn't work.
I looked in my installed programs list and saw that as well as update 16 I had SE Runtime Environment 6 installed.
I uninstalled update 16, revisited Java which said I had 1.0.6 installed and the test worked. Hooray! I installed update 16 again and it worked! Double hooray!
I went to bed happy. Next day applets wren't working again. Visited Java, test wasn't working.
Tried uninstalling both Javas and deleting the Java directory and installed update 16. Now any site with Java causes IE8 to display 'Internet Explorer has stopped trying to restore this website", Firefox just closes.
When I try to uninstall JRE6 I get a message telling me source cannot be found and a browse button.
I did a system restore to the time before I uninstalled both Javas in the hope that at least the browser wouldn't crash on encountering Java, but no luck.
Thank you if you have read all of this, I would be grateful for any suggestions !

  rdave13 12:27 29 Oct 2009

Try uninstalling using Microsoft Windows Installer Cleanup Utility and rebooting and reinstalling the latest version. Scroll down a bit here; click here

Reinstall from here; click here

  f1charlie 12:56 29 Oct 2009

Thanks for reply.

Will try when I get home and let you know.

  f1charlie 20:58 29 Oct 2009

I downloaded the MS Installer Cleanup Utility and installed it, but couldn't find it anywhere! Am I missing something?
Anyway, I uninstalled the latest version and used Javara to remove the older version. Installed the latest (I used the offline update 16 rather than the beta), checked the Java tester and it worked! I rebooted and checked again and as before Java had stopped working! I tried uninstalling and reinstalling a couple more times with no success. As a last resort I looked in the Java control panel and tried deselecting 'Enable the next-generation Java plug-in' and what would you know? Java now works, even after a reboot! I don't know why I can't use this plug-in, but I'm pleased I've sorted it (sort of!)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

iPhone X vs Samsung Galaxy Note 8

Les meilleurs navigateurs internet 2017