Java auto-closure problem

  mnopq 12:22 12 Aug 2011

Whenever I go to a website or program that needs Java I get the message that Java.exe has encountered a problem and needs to shut down - that site is then unusable. I have uninstalled Java using a specialist uninstaller designed to get rid of everything, followed by an "aggressive" registry clean with Regsupreme. I then downloaded/re-installed the latest Java, but I still get the same message. Is there a program designed to fix Java problems?

  birdface 12:43 12 Aug 2011

Maybe remove Regsupreme some fairly poor reviews for it and use C Cleaner instead.

You want the JavaRa removal tool and see if that sorts things out.

  mnopq 19:29 12 Aug 2011

Thanks for the suggestion. I have run JavaRA to remove the old java and reinstalled the latest version. Unfortunately I get the same message - I think the problem is associated with a Microsoft update, but I don't know which one

  birdface 21:00 12 Aug 2011

Ok a few things to try.

If your Zoom is set to over 100%.Set it to 100% reboot and try java again.

Not sure if you can do this but if you can download the new version of java to your computer without running it.Remove the old version again.Reboot into safe mode and then run the new version of java and see if that works.

What it is is that if you have any programs open when trying to install Java you cannot remove it properly as the programs that are open are probably using java.

or download it to your computer start in safe mode.remove Java and install the new version.

I had the same problem and it took about a fortnight for me to fix it but not sure if it was resetting the zoom or installing in safe mode.

  mnopq 16:51 14 Aug 2011

Thanks - I have only just seen your reply. I have run JavaRa again, which seemed mainly to remove registry entries, even though the log stated java had been removed. I looked in my uninstaller and java was still there so I did the "super" grade uninstall, which removed a lot but using "search Java" I found dozens of entries, which probably should be removed manually, although I am worried about side-effects. I propose to do an Acronis image first so I can get back if necessary. I have also run CCleaner and Regsupreme, which both removed so java entries. I did a registry search in regedit and also found a number of entries that could be causing the problem. I do not know what this 100% is - if it is part of java it is too late. Currently I am stopped from using to check my DSL rate and IP profile - if that is the only problem loss of java will cause I can live with it.I have just tried utube and that works without Java.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?