Is it just me?

  Jackcoms 18:38 02 Mar 2005
Locked

Or is using this site like swimming in treacle tonight?

And I'm using a 1mb BB connection.

  Happy Soul 18:39 02 Mar 2005

100% here in Kent. Blueyonder BB.

  VoG II 18:42 02 Mar 2005

Screaming here.

  GaT7 18:48 02 Mar 2005

No problems here - on Stone Age dialup ; ) G

  GaT7 18:51 02 Mar 2005

Try clearing your Internet cache or use another browser to see if it made any difference. G

  Jackcoms 18:55 02 Mar 2005

Internet cache cleared only this morning - and I'll stick with IE, thanks!

  Happy Soul 18:56 02 Mar 2005

Wrong kind of snow? |:/

  CHAIRLEG 18:57 02 Mar 2005

Ok here today was very slow yesterday

  Jackcoms 19:02 02 Mar 2005

Must just be me or the snow or local contention ratios or the price of bread or whatever this evening.

Just done a speed test. Getting about 947 kbps downstream which is about my usual.

Ho, hum. Guess, I'll just live with it. :-)

  dogbreath1 19:27 02 Mar 2005

This site has been playing up (at least as far as my p.c. goes) for the last few days. Hence my recent post. At one point yesterday, I couldn't even get into the log on page. Yet today it's quicker than it's ever been... it's like greased lightening... I can feel a song coming on!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone