IPv4 internet connection issue

  San Alwigi 12:09 13 Jan 2011
Locked

My business partner and i have identical laptops and connect to the internet via a Belkin wireless router that is connected to a cable modem.

A few weeks ago, his laptop became unable to access the internet although it is still connected to the wireless network. No probs with mine.

The main difference I can see between the two laptops is when I compare the Wireless Connection Status dialogue box on both.

Mine (working laptop) shows an IPv4 IP address of 192.168.2.4 and his (non-working laptop) doesn't show an IPv4 address at all it just says "Autoconfiguration IPv4 169.254.209.73". His machine also shows a blank space nbext to the IPv4 Default Gateway and IPv4 DNS Server. His machine doesn't have a IOPV4 DHCP server address like mine either...

His laptop connects to his own wireless network AND internet at his home, no problems.

I think the problem is that his laptop is no longer getting a new IP address from our router (DCHP is enabled on both machines) but not sure why.

Any advice gratefully received, thank you.

  Fruit Bat /\0/\ 15:14 13 Jan 2011

"identical laptops"

MAy be the router thinks they are the same laptop can you heck the routers admin pages and see if the MAC address of both laptops is shown?

  Woolwell 15:19 13 Jan 2011

Try turning off router and back on and then try to reconnect the troublesome laptop.

Flush DNS cache of troublesome laptop.

OS?

  San Alwigi 15:32 13 Jan 2011

Fruit Bat
Yes, the laptops are 100% identical. I'll try that, but they both used to work fine with the same router until a few weeks ago. I do remember that I had connectivity with the router and on Belkin's advice, changed the channel from Auto to 11. Could this have caused an issue. I don't have MAC address filtering turned on, but will check the DHCP client list for a conflict...

Woolwell
Have rebooted router countless times, same difference. Not sure how I would flush the DNS cche, but I'll Google it.

Also - him and his laptop are not here now - he had to go home to get work done. Will try all these things when he is next here and report back. Many thanks.

(PS. me and my compadres Guy Dixon and Oliver Dell actually launched these forums over ten years ago. I haven't been back much recently, (and I think I remember you Fruitbat way back when!). Thanks for continuing to help people like me out!)

  San Alwigi 13:36 14 Feb 2011

OK. Took your advice about DNS flush and looked into the Mac address confusion, but no change.

So I still have a problem with this but here are some new developments:

His laptop connects perfectly with the internet via a wireless network not only from his home, but also from two other wireless networks in other locations that we have tried.

I have invested in a new Belkin Surf Wireless Router (needed to anyway) - but same problem. All other laptops in house see and connect with the wireless network and can access the internet. It appears my business partner's laptop can see and connect with the wireless network but CANNOT access the internet.

BUT - although his laptop says it is connected to my wireless network - his laptop DOES NOT appear in the Network window on either the main desktop PC (which is hard wired to the modem and wireless router) OR any of my laptops.

In the Network window on his laptop, it shows his laptop, ONE of my laptops and it's media sharing files. That's it.

FINALLY - in the networking and sharing centre screen on the laptops that CAN connect to the internet via my wireless network, the network is identified as Belkin (Private Network).

On HIS laptop - which cannot connect to the internet - the network and sharing centre displays the wireless network Unidentified Network (Public network). Could this be relevant?

Any assistance gratefully received as I am doing my nut.

  San Alwigi 13:40 14 Feb 2011

I said:
"BUT - although his laptop says it is connected to my wireless network - his laptop DOES NOT appear in the Network window on either the main desktop PC (which is hard wired to the modem and wireless router) OR any of my laptops.

In the Network window on his laptop, it shows his laptop, ONE of my laptops and it's media sharing files. That's it."

Forget that - his laptop was just a bit slow picking up the other machines on the network. His laptop CAN see the other laptops on the wireless network and can access them.

Still no internet connection from his laptop though!

  San Alwigi 16:14 14 Feb 2011

Have tried the ipconfig /release and ipconfig /renew command prompts before - no change. But I didn't do the ipconfig | find "192" command though - will try that.

Trouble is, I can only do that when my business partner is here with his laptop at my home office - which he is not now because he couldn't get online so he went home!

But we will try again over the next few days and come back to you! Thank you!

And yes...

DHCP was enabled on both machines
DHCP client was running too

  San Alwigi 20:57 14 Feb 2011

That the problem laptop behaved exactly the same way when connected directly to the cable modem by ethernet cable

  San Alwigi 10:47 24 Feb 2011

I don't know what part of your suggested solution worked - but it just did!!

We hadn't been able to try your suggestions until today and bingo - the problem laptop is once again connected to the network and internet. Fantastic!!

We had tried what we thought was everything (we even left the laptop with an IT support guy overnight and he couldn't fix the problem - his suggestion was to re-install Windows!)

This has made us both so happy, we actually just hugged each other, (and we're grown men!)

Thank you so much i24 and everyone else who also offered advice.

Thanks too to good old PCA!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?