IO/subsys error,98se refuses to boot

  Chegs ® 18:12 24 Jan 2004

I have a partition on my pc(running XP Home)that I succeeded in loading an image of 98se to.I have to enter BIOS and set it to boot from SCSI hdd to get 98se loading.First few attempts to get it booting were problematic as I had no optical drives seen by 98se,but early this morning,I had another go,and got 98se booted,with all my optical drives(DVD-ROM/CD-RW/DVD-RW)working.I installed my PCI adsl modem,got online and went to win updates,installed most of the hardware(apart from TV card/SB Live)and went to restart the pc,but it "hung" on shutdown,then "hung" again during boot at the black screen stating "Updating your files,etc"restarted my pc and it will only boot in safemode.Try to get it booted in "Normal" mode produces "IO/subsys error"

I have 1Gb of DDR RAM,which is way to much for 98se,but I cannot remember where to put the "MaxPageFile=40,000" or even if it IS 40000,and is it possible to alter this in 98se partition from XP(NTFS on all partitions but 98se one)Any help would be much appreciated.

  Chegs ® 18:20 24 Jan 2004

Try another HDD. If its not CPU or
IR 'junk' then the HDD might be bad, or the MFS is on a bad area.

Which it could be as XP kept failing to load onto the same hdd,but none of my hdd testers showed any problems with the hdd.

  Chegs ® 19:00 24 Jan 2004

Now getting no errors at all,but trying to boot in Normal mode,causes it to keep restarting.I booted in Safemode,went to device manager and removed/disabled any duplicated devices.Now it just restarting,I'm thinking its possibly a conflict with IE1394 and NIC(IP addys,as XP has had this problem previously)

  Chegs ® 21:19 24 Jan 2004

Sorted,I add MaxPhysPage=30000 to 386enh in system.ini of Windows folder,restart and this limits the RAM available to 98se to 768Mbs.

  VoG II 21:23 24 Jan 2004

That's what I like:

- a clearly defined problem

- a couple of items of clarification

- the solution

And all without any input from other PCA members. Well done Chegs ® !

  Chegs ® 22:15 24 Jan 2004

I was hoping someone might have "been there-done that" but as no-one did,I worked my way thru the various .txt files of 98se,from XP and ran each failure thru google.Most folk haven't got that luxury when their having troubles.I could only get 98se up and running in "safemode" yet I had managed to get it booted normally,until I updated it.Then it refused to boot due to the 'IO/subsys error",google said that was likely a faulty hdd(I have had mths of hassle with XP on this SATA hdd)so I rechecked it with a tester,and again the tester said there was nothing wrong with it,so I retried 98se only it was just looping thru startup screen,this google said was due to my having to much RAM(1Gb DDR)so added the MaxPhysPage=30000,tried 98se again and off it went,no bother(except I had deleted all network adaptors so cannot get it online)Tried several methods to reinstall the "Dial Up Adaptor"without success,so have just reinstalled the "Windows" folder by returning to XP(and typing this whilst its doing it)and using DI/Tools/Options have restored the whole of just windows.Now its finished,I just recreate the "MaxPhysPage=30000" entry in system.ini of 98se,and then reboot it and complete the updating of drivers and get the updates again.Then I have a dual boot of XP and 98se,without being able to create bootloader(due to these SATA hdd's)by simply altering 1st boot device in BIOS.Not ideal,but I have become fairly familiar with the BIOS,particularly since I misflashed it on a K7VZA christmas day a few years ago. ;-)

  VoG II 22:18 24 Jan 2004

"I have become fairly familiar with the BIOS,particularly since I misflashed it on a K7VZA christmas day a few years ago" - I remember it well; I think that was a self-solution as well. LOL.

  Chegs ® 00:49 25 Jan 2004

It resulted in me buying a device called the BIOS Savior,it was a little "piggyback" BIOS chip that could be switched on/off.It took me ages to find out howto flash it with the correct BIOS,as I needed a particular type of mobo with the same type of BIOS chip,I found a mate who had the "use" of his mates K7VZA,I had to go and ask my mates,mate if I could use his mobo to flash my device.Having assured him if I broke his mobo,I would fix it,I was allowed to perform a flash operation on his mobo,at my mates,who refused to have anything to do with the flash.He went off and made a brew:-) (longest I ever waited for a cuppa,as I had a really dry mouth)Once I had the mobo fixed(mine that is)I then went and d/l'ed every single K7 BIOS I could find,and played around with at least 6 different versions,and had a great time messing around with a hex editor,changing bits of BIOS file on the ones that wouldn't

Anyway,back to 98se,got it booted,tried altering screen resolution and it hung.Installed driver for my TV card(having deleted around ten duplicate entries in Device Manager for various things)and it now gets to background screen(after clicking Network Neighbourhood login box)on desktop and crashes,with a white box declaring "EXPLORER.EXE is missing,reinstall windows" and an OK button.I dont recollect if there is a way to repair explorer without reinstalling windows,so it looks like I delete windows folder from XP and reinstall again via DriveImage,modify the system.ini file again,reinstall the drivers and see if I can get it to go.Whilst reinstalling the SB card,I got a message about low memory? but it continued,albeit very slowly.I might just leave it until I have rerun the hdd tester again,as the odd little error creeping in might still be that particular drive is due return to shop as its not fully 8 mths old yet.

  Chegs ® 01:00 25 Jan 2004

click here

Meant to say,does this page say that adding an ; to this line EMMExclude=;C000-CFFF,C000-CFFF,C000-CFFF,C000-CFFF,C000-CFFF like so,stop windows from trying to access this area of memory,or that this area of memory is already being ignored by windows as its faulty/been excluded by the MaxPhysPage=30000 command?

  Chegs ® 01:10 25 Jan 2004

; EMMExclude=C000-CFFF,C000... or here?

  Chegs ® 12:34 25 Jan 2004

; EMMExclude=C000-CFFF,C000 = refusal to load windows,gets to accepting network connection,then desktop pic appears but no taskbar/icons and refuses to respond to CTRL-ALT-DEL.Still getting probs with install of TV cards driver,tempted to remove it completely,as I think its IRQ related with this.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?