Iomega ex 1.5tb HD - will not find.

  andrewmpalmer 13:53 19 Mar 2010
Locked

Hi,

I've had this device for 4 months....no problems, finds ok, hold My pics as backup, My Music as back up, All my DVD's - orginal location....NO BACK UP...about 800 gb worth.

The power lead will find the power, as the light goes on, but i hear no usual wurr noise as it locates and turn on the HDD.

Then obviosly the PC find no 'L' drive as the HDD.

Any Advice, Oh Iomega had no problem receiving the device back, they would send me a new one, or their data recovery co...would like approx £600 to get back the data !!!

I await replies.

Andrew

  Fruit Bat /\0/\ 14:30 19 Mar 2010

"finds ok" ???

do you mean windows find new hardware as in the USB device but it will not show in My computer?

Does it show in disk management?

  andrewmpalmer 14:40 19 Mar 2010

sorry i should have explained better...when i said "finds ok" i meant in the past 4 months, i plugged in the power lead, plugged in the USB lead and hay presto, there its was l drive - HDD, with the stuff inside.

As from this morning, i have the blue light from power being on, but not device found in my computer, and no it does not show in disk management.

When i power it up it normally it makes a wurring noise, and you can hear the disk operating. It shows the blue power light BUT no noises at all.

A VERY PUZZLED ANDREW.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

iPhone X vs Samsung Galaxy Note 8

Les meilleurs navigateurs internet 2017