Iomega 320GB portable hard drive

  mousee 21:07 11 Sep 2010

I bought my son one of these drives for his birthday a few weeks ago and we tried it for the first time today, we did everything by the instructions but the laptop tells us that "windows cannot find the drive" even though when going into "computer" there's an icon for the drive and it states that there is 289GB available, it appears that there is no software installed on the drive, is there anywhere I could find and install the software, I've hunted high and low on the Iomega site but have discovered nothing.

Any ideas?

  Dark Mantis 21:16 11 Sep 2010

Youn don't say which version of the OS you are using but have you initialised the drive?

  mousee 21:28 11 Sep 2010

Using Windows 7, as for initialising the drive????? I got very little paperwork with it, so, no.

  Dark Mantis 21:37 11 Sep 2010

Go into Control panel/Administative tools/Computer management/Storage/Disk management/ and then right click on the offending disk and click "initialise"

  mousee 21:57 11 Sep 2010

Well I've gone through the instructions as you suggest but do not get the initialise option after the right click??????? Can you help me any more please?

  hastelloy 03:48 12 Sep 2010

Start<right click on Computer<Manage. Under Storage select Disc Management. Right click on the disc and select format.

  gazzaho 08:30 12 Sep 2010

I own an Iomega eGo 250GB drive myself, there's no drivers to use with it, you just plug in and go.

It was formatted as Fat 32 and I didn't need to initialise it, most external drives are plug and play, you plug them in and windows detects and installs the drivers, have you tried unplugging it and plugging it in again?

Now and again when I plug mine in it doesn't get detected properly and windows reports the drive isn't connecting at the right speed unplugging it and trying again usually fixes it.

I suspect the drive controller on the drive is a little flakey at times myself.

  mousee 11:24 12 Sep 2010

I've tried formatting the disk as both NTFS and FAT but the laptop can see it but will not recognise it, the message I'm getting is "windows cannot find the disk where your backups are being saved". Could the drive be shagged?

  Fruit Bat /\0/\ 11:28 12 Sep 2010

"the laptop can see it

windows cannot find the disk where your backups are being saved"

this sounds as if the drive letter is changing when you plug it in.

What drive letter is the backups being sent to?
In Disk management Assign the correct drive letter to the Iomega

  mousee 11:44 12 Sep 2010

The assigned letter is E

  Fruit Bat /\0/\ 11:49 12 Sep 2010

IS the Iomega set to E?
Are the backups set to go to E?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

Halloween Photoshop & Illustrator tutorials: 20 step-by-step guides to creating spook-tacular…

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?