Iomega 250 zip drive [internal]

  drbes 13:31 08 Dec 2005
Locked

Using Windows 98SE. Intermittent problem with internal Iomega 250 zip drive in that inserting a zip to copy files to or from either goes OK or the green light on the drive just stays on as if it's reading the disc and then a message comes up asking if I want to format the disc or not. Cannot eject the disk as nothing on screen works apart from this message box [not frozen - just nothing works]. Have to manually shut down and restart to get the zip disc out. The problem appears to be increasing from about once a month to two or three times a week over the past 6 months. Happens now about one out of 10 times of using with any disc, old and brand new, even with new ones that have nothing on them still. Tried testing out numerous old and new discs and bought a load of new ones recently and it does this with them also even though they have nothing on them yet. Not always the same discs are affected by this either and seems to be very random. Sometimes as soon as I insert the disc I get a black screen or a blue screen with error message re OE in VXD in disk TSD 03 from Voltrack. The rest of the time all works fine and as it should do. I use zips to copy any file used during the day to the zip for backup so am using them quite frequently each day. Any suggestions as Iomega don't seem to have an answer to this one?

  Diodorus Siculus 13:37 08 Dec 2005

Try running the system file scanner start, run, sfc

As an alternative, it might be time to get a USB thumb drive; they are cheap and convenient nowadays.

  drbes 16:00 08 Dec 2005

Done that and whole computer checked thoroughly and nothing showing untoward. I also use a flash pen for storage and transfer to another computer. I store most things on zip discs on a daily basis rather than CDs and then copy all to CDs monthly. I think it may be a driver problem or some connection playing up? Just wondered if anyone else had a similar problem and how they solved it.

  DieSse 17:02 08 Dec 2005

I suspect your ZiP drive is starting too produce a few too many read errors - when you get a read error on inserting a cartridge then the disk is not read and it assumes it needs formatting.

It may be dirty heads, it may be positioning errors.

You can get ZiP head cleaners - I won't endorse them, and many people say they are dangerous to use. So be warned.

Have a read here click here see the other links about ZiP at the foot of the page.

Most likely is that your drive is beginning to expire slowly.

  drbes 20:41 08 Dec 2005

Tried a zip head cleaner but it ejects as soon as I insert it. The drive is only 6 months old. I could understand this all if it was old zip discs it was happening to but it happens with brand new ones straight out of the packaging and inserted into the drive before anything is copied to or from them and it's so intermittent. Will check out the link you give and see what it shows. Thanks meantime.

  Newuser38 21:37 08 Dec 2005

Have you tried the Iomega site click here hope that link is ok if noy go to click here and the follow the link to Europe and to customer support/help

  drbes 21:52 08 Dec 2005

Been in touch with Iomega but they cannot give any definite answer to the problem other than the standard answers of checking every connection, checking drivers, etc. All that has been done and running out of ideas. Maybe the drive itself is defective and getting worse?

  woodchip 22:03 08 Dec 2005

If I was You, Get all Info off disc's, the Drive is on it's way out. Then remove and Use a DVDRW drive for your backups

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Converse draws on iconic heritage for a fresh brand identity

Mac power user tips and hidden tricks

Comment lancer Windows 10 en mode sans ├ęchec ?