Iomega 100mb zip drive, installation problems

  nebuchan 23:10 21 Sep 2005

I am having issues with a parrallel port iomega 100 exturnal zip drive.

It is used for backing up important business files on a dinosaur computer, circa 1996 i think, It worked fine running on win95, however the owner wanted to have broadband on the computer so upgraded to a faster win98se machine.

I have folled the installation instructions, and innitially i had the extra iomega drive in my computer, and was able to tranfer data from the old pc to the newer one.

I then went to install the printer (running through the zip drive) and added the computer to the home wired network.

The iomega drive dissapeared and refused to open any zip disks.

I tried reinstalling it, but it cannot read the tools disk from the iomega drive.

I am thinking the printer installation may have altered the parralell port in some way.

I have downloaded the latest drivers as well, but nothing seems to work.

I any one knows of any way to get this drive to work, you would be a great help!


  woodchip 23:15 21 Sep 2005

Best thing to do with that is get things of it and bin it. use a DVD or CD RW drive

  woodchip 23:16 21 Sep 2005

I remember the trouble with Syquest drives only too well. thay worked on same lines

  DieSse 23:37 21 Sep 2005

You could try with fitting an extra parallel port card - they usually cost peanuts - this would put the printer and drive on seperate cables, and most likely fix things. eg click here

  nebuchan 00:05 22 Sep 2005

If it were my computer i would personlly bin it and replace it with a usb flash drive, which has more capasity and is faster. However it is for my Girlfriends dad, who is a bit reluctant to learn something new. So ideally i would like to get the iomega zip drive working, and i know it does work!

Ive now put the printer to a usb cable, so it is not connected through the zip drive, though it still refuses to be reconised as a drive.....


  DieSse 00:15 22 Sep 2005

Check in the BIOS that the parallel port is set to the type EPP (also try ECP) - but definately not Standard or SPP.

Uninstall any old printer software - some Epson printers install parallel port control software.

  nebuchan 00:24 22 Sep 2005

i am not too familiar with messing around with the bios, but your probably right about the epson parallel port control software, however i have already unistalled the software, but to no avail.

  User-312386 08:33 22 Sep 2005
  User-312386 08:35 22 Sep 2005
  nebuchan 09:07 22 Sep 2005

i think i have already tried that, and to no avail, but i will try again, cheers

  xania 10:37 22 Sep 2005

The Iomega driver software is constantly being updated. If you've used the software that comes with the kit, you will almost certtainly find problems. I suggest you uninstall it and download the most up-to-date version from Iomega. One of the problems you will find is that this will not enable you to read existing backups created by older versions of the software.

A better alternative, which may solve all your problems, would be to move to a USB or internal version of the hardware. There's loads on Ebay and you could pay as little as £5 + P&P - certainly works faster than the old parallel port version.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review

How to draw a mandala

iPhone X review

Les meilleures enceintes Bluetooth à moins de 150 euros