I/O device error on C:

  i.tech 16:35 06 Mar 2011
Locked

We have an Acer Aspire 5920 laptop. When attempting to boot it takes several minutes an eventually boots to System Recovery Options. This states 'choose an operating system to recover' but the box is blank.

When attempting to access the C:\ drive from the command prompt (as standard it goes to x:\) the error 'the request cannot be performed because of an I/O device error.

We can access the d:\ drive an get an accurate list of files when using dir. I assume this is a partition rather than a separate drive.

Any ideas??

  rawprawn 16:46 06 Mar 2011

Can you get into Safe Mode and check drivers in device manager

  Fruit Bat /\0/\ 16:52 06 Mar 2011

Interesting,
the C: D: and X: drives are normally partitions on the same hard drive with X hidden(recovery tools)

I/O device error usually means cannot connect to the physical drive, but you can get D and X?

I can only assume that the MBR for C is damaged may be smething click here can help.

  Fruit Bat /\0/\ 16:53 06 Mar 2011

click here your other thread is this the same problem?

if so click resolved on the other thread to prevent confusion.

  i.tech 18:45 06 Mar 2011

Thanks for the responses.

Rawprawn: no, only two options - boot to Windows normally or boot to Sys Recovery.

Fruitbat: oops, sorry, had problems when trying to write it in on the iphone, didn't realise the other thread had saved.

Upon further investigation it looks like the X: drive is actually what I would nomrally expect to be the C: - when I run a dir I get Windows, program files etc, D seems to be an additional partition which contains photo's and the like (sorry, working on my bro's laptop so didn't initially realise this) and C: is possible the DVD drive, maybe the source of the I/O error?

When trying bootrec /fixmbr I get operation completed succesfully but system still will not boot into windows normally.

When trying bootrec /fixboot I get 'the volume does not contatine a recognized file system. please make sure that all required file ssytem drivers are loaded adn that the volume is not corrupted'.

When trying bootrec /scanos I get (worryingly) 'Succesfully scanned Windows installataions. Total identified Windows installations: 0. The operation completed succesfully'.

When trying bcdedit I get 'The boot configuration data store could not be opened. The system cannot find the file specified'

I should probably also mention that everything is seriously slow, not just boot-up. Even selecting from a drop down menu in the Sys Recovery is taking upwards of a min?!

  i.tech 18:58 06 Mar 2011

"C: is possible the DVD drive, maybe the source of the I/O error?"

Sorry no, the DVD drive is actually on E!!

  Fruit Bat /\0/\ 20:58 06 Mar 2011

Now you have fixmbr done try the startup repair again hopefully it will now find the operating system.

If not then from the command prompt try running chkdsk

  woodchip 21:06 06 Mar 2011

Try removing the Hard Drive and refitting it. With Power off and Battery removed

  i.tech 18:29 08 Mar 2011

I have tried another system restore but get the message "Windows cannot repair this computer automatically"

When i tried chkdsk from command prompt I get "The type of teh file system is NTFS" then it freezes.

I have tried reseating the HDD however this also is to no avail.

  Fruit Bat /\0/\ 18:44 08 Mar 2011

Is there anything on the hard drive you REALLY need?

If NOT then boot from the DVD and do a Full reinstall

  woodchip 18:49 08 Mar 2011

It looks like the Drive as bad patches, Doing a Install will not clear the patches. If these are not marked out by Check disc or another program windows will try writing these bad blocks

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Lightwell software lets you create mobile apps without using code

Best value Mac: Which is the best £1249 Mac to buy

Comment désactiver les programmes qui s'exécutent au démarrage de Windows 10 ?