Invalid Procedure Call or Argument

  recap 22:37 09 Jul 2007

Of late I have been getting the above error message on this computer - Window XP Home.

I have trawled the net only to find the most relevant thing being for Visual Studio 2005. I looked on MS knowledge base for a solution, did the necessary updates and patches. But I still keep getting the above error.

I have also conducted a full and deep scan with anti-virus, spyware, maleware, check the event viewer still nothing.

Any thoughts would be appreciated.


  skidzy 23:05 09 Jul 2007

Do you have the .Netframework 3.0 installed recap click here

Just guessing here,have you recently tried to install some latest released software ?

Im thinking this is going to be over my head,after reading up on this.

  recap 08:54 10 Jul 2007

Thanks for that skizy, your link doesn't show anything other than MS search page.

I do have .net on my computer.

Thanks for the train of thought, I will look for info on .Net

  €dstowe 09:11 10 Jul 2007

That's similar to the messages that come up with the old Sasser worm and its relations.

Might be worth running Stinger click here

  recap 09:33 10 Jul 2007

Thanks €dstowe, I have stinger on my system but never thought of running it as the virus scan found nothing.

Will give it a try when I get home tonight.

  €dstowe 09:58 10 Jul 2007

Don't forget to update Stinger - an old version might not work properly.

  recap 10:02 10 Jul 2007

Cheers €dstowe

  skidzy 18:52 10 Jul 2007

The link ive supplied recap,should show the Netframework 3.0 download page.

If you are not getting that,then something is amiss with your settings or possibly as €dstowe has pointed ....a virus.
Maybe an online scan with Trend or kaspersky or even Panda will help.

  recap 19:50 10 Jul 2007

Thanks skidzy, I have Panda on my system.

  recap 10:13 11 Jul 2007

Well what a pa-larva last night. I ran Stinger and it got rid of the virus/hacker (Qttask.exe). I rebooted only to find that it was back again. I re-ran Panda and my malware programs and it was still there. I then tried CWshredder, which advised me to install a new version of the program to get rid of the virus/hacker. This found it straight away and I was able to delete it. To double check I re-booted only to find it back again.

I then asked my sons if they had been on the computer. One of them admitted to opening a port on the router so he could download a movie, AAARRRGGHH!!!!!

Port closed now and an encrypted password on the router this time.

Thanks for all your help folks.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

This is what design agencies will look like in 2032

How to update iOS on iPhone or iPad

WhatsApp : comment lire vos messages sans que l’expéditeur le sache