Internet slows down when a browser is used or download is attempted

  badgerdds 06:52 09 Apr 2015

Hi All

I'm really in desperate need of some help

Whenever I open a browser, be it IE, Chrome, Firefox, etc... the internet immediatley drops through the floor. However, If i have no browser open my upload/download speed is completley normal; I can only assume this is being caused by some type of virus? (there are no extensions or addons in any of the browsers)

All other devices, laptops, phones, etc all work normally, it's just my computer

I have tried every thing I can think off to fix the issue:

  • Run antivirus
  • run anti-malware
  • disabled system restore, run system restore, booted in safe mode, run antivirus/malware
  • used netstat to try track down any strange open connections (none could be found)
  • wiped the hard drive (restored back to factory)

nothing seems to work!

when i run a ping request, it starts off normal at 20ms.... .then as soon as i open a browser, or try to download something... it drops right down to 1400ms(av)!

Please... if anyone can suggest anything else i can try that would be really helpful

Thank you in advance

OS Name: Microsoft Windows 7 Home Premium OS Version: 6.1.7600 N/A Build 7600 OS Manufacturer: Microsoft Corporation OS Configuration: Standalone Workstation OS Build Type: Multiprocessor Free Registered Organization: Product ID: 00359-OEM-8992687-00093 Original Install Date: 07/04/2015, 22:10:07 System Boot Time: 07/04/2015, 22:57:01 System Manufacturer: MEDIONPC System Model: MS-7658 System Type: x64-based PC Processor(s): 1 Processor(s) Installed. [01]: Intel64 Family 6 Model 37 Stepping 5 GenuineInt el ~3200 Mhz BIOS Version: American Megatrends Inc. A7658MLN.103, 10/06/2010 Windows Directory: C:\Windows System Directory: C:\Windows\system32 Boot Device: \Device\HarddiskVolume1 System Locale: en-gb;English (United Kingdom) Input Locale: en-gb;English (United Kingdom) Time Zone: (UTC) Dublin, Edinburgh, Lisbon, London Total Physical Memory: 4,023 MB Available Physical Memory: 1,651 MB Virtual Memory: Max Size: 8,044 MB Virtual Memory: Available: 5,888 MB Virtual Memory: In Use: 2,156 MB Page File Location(s): C:\pagefile.sys Domain: WORKGROUP [72]: KB983590 Network Card(s): 2 NIC(s) Installed. [01]: Realtek PCIe GBE Family Controller Connection Name: Local Area Connection Status: Media disconnected [02]: Realtek RTL8191SU Wireless LAN 802.11n USB 2.0 Network Adapter Connection Name: Wireless Network Connection DHCP Enabled: Yes

  DipanshuBajaj 14:49 09 Apr 2015

first of all hello I dont know much about this but this is just a suggestion Since all of the above methods proove fatile make a linux live usb and then run internet on it and then check if you can get right speed and this would just confirm that internet speed is all right

and just another suggestion if you dont have your problem solved, try that in a virtual machine by using bridge connection

  badgerdds 23:10 10 Apr 2015

So I managed to solve this on my own (eventually)....

step 7 and 8 solved the issue for me

So, in case anyone else is having the same problem, here are the steps I took to solve the problem:

1) Restart the computer 2) Disable system restore, then restore computer back to last know working configuration. Restart the machine in safe mode, and run an antivirus scan/malware scan 3) try running programs like, rkill, glasswire, combofix, etc to try reset and flush typical stuff out 4) using the cmd prompt, run 'netstat -b', look for any abnormal PIDs, if you see any, use the 'msconfig' cmd, disable any processess/services. Then use regedit to manually remove the entries. Open the folder c:/computer/user//appdata/local/temp and delete all the contents. restart the machine 5) go to control panel, network and sharing centre: click on the wireless connection. when the prompt opens, click on 'properties', left click on IPv4 and click properties again, in the bottom section, input an open DNS address (you can find loads on google) 6) Hard reset your router (usually a pinhole button on the back of the router) 7) log into your router through the default gateway (ipconfig to get the ip, then stick that into your browser). Go to router settings and find your security settings. Change the wireless channel to the next one down (for me, I changed mine from 11 to 8), then, change the security encryption to 'WPA(only)'

I hope this helps

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment utiliser Live Photos ?