Internet Explorer Problem

  prima12 18:25 17 May 2007

Hi, I opened up a discussion thread 'What do you think of these? Opinions please'.I opened a link from *THE RAVEN* for the ebuyer site, I then get the following message:-

Runtime Error
-pure virtual function call

I then press the OK and the Internet closes, any suggestions please, I have tried other links in other threads and they are OK. I have tried to repair Internet Explorer, but on re-booting I get a message:-

'An error or exception occurred while calling the function "DllRegisterServer"in "C\WINDOWS\Start Menu\Programs\Internet Explorer\hmmapi.dll"

I have downloaded 'hmmapi.dll' but it asks me what I want open it with and I don't know, also how do I install 'hmmapi.dll' into the system? Sorry it's so lengthy. P.

  skidzy 18:36 17 May 2007

Looks like your IE is corrupt.

What version of IE 6 or 7,if 6 try this click here

Also try the system file checker

Start/run and type sfc /scannow and enter

Understanding sfc click here

  Technotiger 18:41 17 May 2007

Hi, I agree with skidzy, run CCleaner this may well fix it.
click here

  prima12 21:16 17 May 2007

Thanks for your replies. I am using the old W98se with IE6, I've run IEFix, as this also applies to W98, and I had previously run Ccleaner and thought that it may have been responsible for the problem so I reinstalled the 'backup' file, but no difference, could it be the ebuyer website that is at fault, I don't get a problem with any other links?P.

  prima12 21:25 17 May 2007

Just as an add-on to my previous reply, I went onto the ebuyer site and anything I select to view gives me the same message. P.

  Technotiger 21:28 17 May 2007

Hmm, as you don't have any problems with other links, I would guess that the site in question in conjunction with THE RAVEN's link, has a fault.

  skidzy 21:37 17 May 2007

What happens when you click on this link click here

And when you click buy ?

Can you post a screenshot of your problem.

Ebuyer site seems to work fine here.

  skidzy 21:39 17 May 2007

If you still cannot access my link or the buynow option but all other sites are fine,try with your firewall disabled briefly.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Converse draws on iconic heritage for a fresh brand identity

Mac power user tips and hidden tricks

Comment lancer Windows 10 en mode sans ├ęchec ?