internet connects but cannot access any web pages

  wendy price 21:07 25 Jun 2008
Locked

I have been connected via my Laptop which is wireless enabled with no connection issues or problems at all. Router is a Echolife hg520s.

I then tried to connect my desktop to the router via a Belkin G+MIMO network card.

The desktop will say it is connected but I cannot access the internet, it comes up with the Error DNS server error.

I have tried various things listed within this forum, including manually putting in IP address and DNS. Resetting everything incluiding deleting the Drivers for the PCI card. After trying most things. I am ready to throw the desktop. Please could somone help.

  brundle 23:13 25 Jun 2008

Network problems can be logically tackled, a couple of tests can establish which elements of the configuration are correct and working, and what needs looking into.

What stage are you at?

Card installed, drivers installed?

Any security enabled on the router?

When you connect to the Echolife, open a command prompt and get the IP information.

Vista or XP? The procedure is slightly different...

  wendy price 21:27 26 Jun 2008

Today completly uninstalled drivers, card and router from both the laptop and desktop. Reset router and installed drivers and talk talk software to the desktop first, it connected wired and wireless to the router but still would not start webpages and it was restarted. Showed limited or no connectivity. Manually entered IP address and DNS server which i had recorded after re-install. This allowed full connectivity to the router but no connection to any web page.

Settings used were IP address 192.168.1.200 for the desktop, 192.168.1.1 for gateway and DNS which was exactly what i recorded.

No joy!!! still only connected to router.

Turned desktop off and started re-install to the laptop, found everything straight away without any problem, didnt even have to enable anything did all connections for me.

Am currently still using Laptop for everything.

Both systems use Windows XP, have turned of the firewall.

  brundle 06:54 27 Jun 2008

So now you have no webpages on both machines, one machine?

I am going to assume at least one machine is still unable to bring up webpages.

Did you configure the settings manually on that machine? It ought to be giving connected machines an IP address automatically (and is, as your laptop found it and was configured OK).

Get the full IP information from the problem machine. Make sure it is set to obtain an IP address automatically. click here

Post back with IP address, gateway and DNS addresses.

Still at the command prompt issue the following commands.

ping 64.233.167.99

then

ping google.com

You should see something like this with both;


Pinging google.com [64.233.167.99] with 32 bytes of data

Reply from 64.233.167.99: bytes=32 time=108ms TTL=239
Reply from 64.233.167.99: bytes=32 time=111ms TTL=239
Reply from 64.233.167.99: bytes=32 time=105ms TTL=239
Reply from 64.233.167.99: bytes=32 time=107ms TTL=239

Ping statistics for 64.233.167.99:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 105ms, Maximum = 111ms, Average = 107m

If the IP address one works and the site-name one doesn't you have connectivity but DNS is not working or incorrectly configured.

If both work the problem is further up the network stack. A Winsock fix can often solve it - click here

  wendy price 20:36 27 Jun 2008

Tried the ping 64.233.167.99 - responded with time out, no response.

Its the Desktop that is still not working. Laptop fine, connected straight away after reset.

Desktop will connect to server if i manually input the IP address, gateway, and DNS address.
IP adress 192.168.1.XXX, tried 3,200 and 45, as i was told to try various adresses which were not the same as the router or the laptop.
Gateway was input as 192.168.1.1
DNS was input as 192.168.1.1

If I allowed the desktop to find the Adresses automatically then it will not connect properly and will only have limited or no connectivity.

What next???

  brundle 12:50 28 Jun 2008

So no connectivity at all on the desktop with IP set to auto-configure.

When you manually configure do your pings work? Can you access the internet?

Go to start/run, type

services.msc

press return

Check that the DHCP Client service is set to Auto and started. If it isn't, make it so. Then set the PC to auto-configure TCP/IP again. Is the desktop connected via cable or wirelessly?

  wendy price 14:31 28 Jun 2008

No, there is no connectivity if I allow desktop to connect automatically.

When i configure the desktop manually and tried the ping 64.233.167.99, got response timed out.

Typed in the services.msc and the DHCP client service is set to Auto.

Tried the Desktop wired, when resetted eveything, couple of nights ago. worked fine and connected to the Internet. Then tried wireless, worked initially and connected to the internet until i turned it off and restarted it.

I know its a pain but please please help me.

  brundle 16:15 28 Jun 2008

If you have no internet connection even when you manually configure the IP address then you need to check the most basic of things - cables, devices enabled/disabled, link lights on the router etc. Manually configuring won't automatically create the connection, it only means you won't see the `cannot assign IP address` warning that Windows will normally display when it's set to autoconfigure and can't get the relevant information from a DHCP server (the router) - you still have the same problem.

Having said that, you need to ensure the router has DHCP enabled too and a reasonable IP address range it can allocate - if the range has been restricted to one address then you will only ever get one machine to connect at once.

Switch both machines on, with the desktop set to autoconfig TCP/IP.
What IP addresses have the machines been given?
Need to know both, even if the desktop one starts 169. and it can't get an IP address from the router.

  brundle 16:16 28 Jun 2008

Also check your router's security settings - if MAC filtering is enabled, ensure the MAC addresses of both machine's wireless network adapters are on the list.

  wendy price 21:59 01 Jul 2008

Sorry for delay, in trying to reset the router. Lost connection to both the laptop and desktop. took till now to get it back.

I believe the router is somehow set up to pick just the one PC up. As its only picking up the MAC address of the laptop.

The Laptop picks up the right IP address straight away.

The Desktop comes up with the default IP 169.xxx address.

Where do I go from here??

I really appreciate the help your giving me Brundle.

PC world have quoted me loads of money which i dont have to come and sort.

  joebloggs1 00:14 02 Jul 2008

Have a look at my response in this thread (about 5 down). Links to what I needed to do when I could connect to the interent but view no web pages.
click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?