Internet connection problem win 7

  DeeW 11:53 19 Apr 2010
Locked

I have an intermittent problem which has just resurfaced recently. On startup I get a warning on the network access icon that the internet is not connected. On running resolve problems in the network and sharing centre the connection is made. The problem found message is 'local area connection does not have a valid IP configuration' fixed. When I restart, the problem reoccurs. My router is wired LAN connected.

  rawprawn 12:01 19 Apr 2010

Try flushing the DNS.
Open the command prompt (Run as administartor)
In the command window type the following and then hit enter: ipconfig /flushdns

  mgmcc 12:03 19 Apr 2010

Open the Services window ("Start > Run", type SERVICES.MSC and click OK) and double click the DHCP Client entry to open its Properties sheet. Make sure the service is "Started" and that its Startup Type is "Automatic".

If that's all OK, and the PC is continually failing to get its IP address automatically, you could give the Local Area Connection a fixed IP address. Post back if you need instructions on how to do that.

  rawprawn 12:06 19 Apr 2010

I should have said when you have done what I said in my first post
Then type,
net stop dnscache and press enter
followed by,
net start dnscache and press enter.

  DeeW 13:39 19 Apr 2010

Thanks mgmcc The service is started and the startup type is automatic. Perhaps I could try a fixed IP address if you could post instructions.

Rawprawn - tried your suggestion - no luck!

  mgmcc 13:56 19 Apr 2010

>>> Perhaps I could try a fixed IP address if you could post instructions.

Firstly you need to know the IP address of your router. Open a Command Prompt window ("Start > Run", type CMD and click OK), type in...

IPCONFIG /ALL

...and press Enter. This will display details of all network adapters installed in the PC. Look for the address of the DEFAULT GATEWAY and that's your router's address. Make a note of it - it will probably be 192.168.x.1 but the third octet (number) varies between makes.

Now go into the Network Connections folder ("Start > Run", type NCPA.CPL and click OK), highlight the entry for the Local Area Connection, right click it and select Properties.

In the Properties sheet that opens, click the entry for "Internet Protocol Version 4 (TCP/IPv4)" and then click the Properties button. Click "Use the following IP address" and type in...

IP address - 192.168.x.5 (where 'x' matches that of the router's IP address)

Subnet Mask - 255.255.255.0

Default Gateway - 192.168.x.1 (the *ROUTER'S* IP address)

DNS Server address - 192.168.x.1 (the *ROUTER'S* IP address)

(Leave the second DNS server entry blank)

Note: To revert to automatic IP addressing, set *BOTH* IP and DNS sections back to obtaining their addresses automatically.

  DeeW 22:44 19 Apr 2010

Thanks mgmcc

I followed your instructions but got an error message 'another computer on this network has the same IP adress as this computer' so coudn't apply the settings.

  birdface 08:07 20 Apr 2010

ipconfig /flushdns remember to leave a little gap between ipconfig and the forward slash or it will not work.
it should tell you DNS cache has been flushed if so reboot and see if it works any better.

  mgmcc 09:22 20 Apr 2010

>>> I followed your instructions but got an error
>>> message 'another computer on this network has
>>> the same IP adress as this computer' so coudn't
>>> apply the settings.

I selected the address 192.168.x.5 thinking it would be a safe bet that the address ending in 5 wasn't already in use in the network. Try changing to 192.168.x.20 (again with the third octet matching that of your router's IP address).

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

5 best 3D model websites

iPhone 8 vs iPhone X

WhatsApp : comment lire vos messages sans que l’expéditeur le sache