internet connection with linux

  2020 18:07 29 Dec 2008
Locked

hi, my neice got an acer aspire one netbook and i can't get connected to the internet. i tried directly pluging in the ethernet cable from the cabel modem [virgin]no luck. i had tried to get wi fi connect via the fon router but it only picks up the public access connection but not the my place connection. as its not windows i don't know what to do. hope you can guide me thru step by step.
many thanks in advance
m

  2020 18:16 29 Dec 2008

BTW, meant to say that when i go into WALN Settings i don't know what Encryption type: WAP & WPA" Personal is and therefore don't know what the password would be. i have tried the S/N on the bottom of the router but its not doing anything.

  realist 19:02 29 Dec 2008

Do you have wireless enabled on your router?
If so, then if the wireless tower is switched on on your netbook it should pick up the signal and give tou the option to connect to the router by entering a passkey.

  2020 19:14 29 Dec 2008

hi realist,
yes i have a La Fonera wireless router and it picks up other laptops no bother. i can get into the public FON_AC connection, howvere it wont pick up the My Place connection and i can't follow what is offered because its not windows and i don't have knowledge of the other system. if that all makes sense

  realist 19:29 29 Dec 2008

I'm not familiar with that particular router so I'll defer to someone who is.

  realist 20:06 29 Dec 2008

Might be worth checking here?
click here

  2020 23:36 29 Dec 2008

hi again realist,
thanks for the link, had a quick look but cant see my issue. will return to it. many thanks for your help thus far.
mary

  LastChip 00:30 31 Dec 2008

I'm afraid it's got a bit of a reputation for not being the best in the world, but see if you can manage this.

Open up a "terminal" and type the following command and then hit enter:

ifconfig -a


What you are looking for is the inet addr: for either eth0 or eth1 - depending on how the computer is configured. Please post that information back here.

Sadly, although it seems a lot of these machines have been sold, I've yet to see one to work out how it's set up. So it's a bit of suck it and see!

However, most of these consumer type Linux machines do have a reasonable graphical user interface to set up networks and similar, so a look around would not go amiss. Look particularly for a "system" icon, as often, everything you need is there. Having said all that, Linux computers normally connect to a router without any hassle, so are you sure the router itself is set up to provide an IP address? In other words, it's a DHCP server?

  2020 10:44 31 Dec 2008

Hi LastChip
im not sure i understand what you terminal means?
i have taken the netbook to another location and it picks up the wirless first time. it will still only pickup the Fon_AP public connection. i'll have another try when i figure out how i open the terminal. it is identifying DHCP. maybe another touter is the best solution..any suggestions, i notice they have become very expensive about £50, the last one i bought was about half that!
many thanks
m

  LastChip 11:20 31 Dec 2008

The icon looks like a little TV screen and it is a way to run commands in Linux.

As regards your router, I notice you said you were with Virgin. Is that via cable or a normal telephone line, as it will make a difference as to which router you need.

I'm glad the computer works well elsewhere, as normally Linux does not have any problem with networks. In fact, it's one of it's strongest points.

click here for something I wrote a week or so ago, that answers some common questions.

Another one of my contributions, click here may also give some basic insight into what Linux is all about. It a strong (fantastic) system, but as you've found, needs a little work to learn how things are done. But a small investment in time will reap dividends.

  realist 11:27 31 Dec 2008

To open a terminal on the Acer One I think it's Alt+F2. If this doesn't work look in "My Files" and see if you can find "terminal" in the file menu.
You should end up with a black box and a white flashing cursor, type in there as LastChip's post above press enter and post back to him.
Hope this helps.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone