This internet connection has me scratching my head

  awest3 17:33 11 Apr 2008
Locked

I'll try and keep it short..Dell Dimension 5000, 3.4mhz pentium 4,XP SP2, 3gig memory, 750 gig of disk space on 2 drives. Use AVG, CC, MS firewall, registry mechanic and spybot.
Got a new Sky connection (using their router with WAP)
all ok on day 1, day 2 can't get on, talk to Sky who offer suggestions but all tests appear ok, look at my network connections and find my Broadcom internal NIC disabled, try to enable but no joy. Decide to do a restore to the day before I got Sky...all up and working and I decide that I must have done something to an IRQ or similar..works for a week no problem. Then today I cant get on for quite a while in the morning, can't see anything obvious and the inetrnal nic seems to be ok...then all springs to life...

I decide to leave the router switched on to see if its starting up it does not like (I'm suggesting its the router at this point but as we will see I don't think it can be).
This pm came home turned on the PC and it can't connect....internal NIC card is disabled again..try to enable no joy even using the broadcom suite (by the way the code it shows says 22 but I can't at the moment fid a reference to it anywhere as yet.

So I pull out my laptop and it can get onto the internet no problem through the wireless link.

I try my desktop again and its working (I'm writing this on it) ...the internal/onboard NIC is working ok..
The last time I tried to fit an external NIC but the installation kept failing and would not install.....

Any suggestions welcomed any additional info please ask...I can't imagine that my onboard NIC card has decided to become dodgy at the same time as I swith IPS's (Speed on Sky is 4 times what I got with Pipex and a third of the price...no good if I can't use it though)

Al

  awest3 17:38 11 Apr 2008

forgot to mention , when the NIC goes disabled there is a red cross against it in device manager.

  tullie 17:38 11 Apr 2008

Dont know if its an help but they usually have WPA encription,not WEP.

  Fruit Bat /\0/\ 17:39 11 Apr 2008

Code 22 (From MS)
This device is disabled. (Code 22)

Recommended resolution
The device is disabled because a user disabled it by using Device Manager. Click Enable Device. This starts the Enable Device wizard.

This error is occurs when no IRQs are available on the system and either the BIOS or Windows disables the device. A red X should be apparent on the adapter in device manager, and in the properties window the "disable from all hardware profiles" box should be checked. To resolve this issue the Ethernet adapter will have to be completely uninstalled from the system and some reosurces will have to be freed up on the system before the Ethernet adapter can be properly instaled (changing the PCI slots may also solve the issue).

  awest3 17:52 11 Apr 2008

Hi Tullie, yep it is WPA...I thought one thing and wrote another...

Al

  awest3 17:57 11 Apr 2008

Hi Fruitbat, thanks for this...not sure how I went from my old netgear 834gt router working ok for 3 years to suddenly having a conflict with the new router..as its an onboard N/A I can't swap the PCI slot over...is there anyway I can spot/check where the conflict is or why it goes away after a short time..? or can I change the irq to a different one.....

Any idea where this came from in the first place..ie.e what would have to have changed to suddenly make it behave like this..?

Thanks Al

  shellship 18:02 11 Apr 2008

Don't know if it is relevant but if one installs BB from a new ISP using their installation disk they do like to take over your machine in ways you may not like. Have you tried the Sky Users Forum to see if anyone else has had this problem?

  awest3 18:06 11 Apr 2008

Hi shellship,

Good thought to try the Sky forum, I have been on there previously but that was to try to use my old router with my sky isp...there seem to be ways to do this but I was not successful...I did put the Sky disk in and run it maybe there is a way to back these chnages out..

I'll report back later

Al

  woodchip 18:27 11 Apr 2008

Something to check in Device Manager, Go to the nic and check what power management is set to. it may think its a laptop, and turning its self off

  awest3 18:41 11 Apr 2008

Hi Woodchip,
Strange you should mention that, someone suggested that the card was going to sleep and that I should switch the flag on which says to wake up the card if the machine has been into sleep or hibenation mode...but this happens when even when powering up the machine from scratch. Leaving the router powered up also makes no difference..

Thanks Al

  woodchip 18:58 11 Apr 2008

Also check BIOS power settings

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

50 best online Adobe XD tutorials

iPad Pro 10.5in (2017) review

Comment connecter un MacBook à une TV ?