Internet Connection

  SURVEY 20:31 06 Nov 2009
Locked

I am trying to update a neighbour's laptop, using my home braodbacnd connection. Running on XP2. Has AVG 8.5 and uses Windows Firewall.

With great difficulty I have got the laptop to accept my broadband wireless connection. I can access the internet to carry out a windows update but after a short while the connection appears lost yet the wireless icon on the system try indicates a good connection. Only option is to restart and then it goes for a while before cutting out again. I do not have these problems with my own computers using the same connections. Incidentally I did take off the firewall but this made no difference. Any ideas?

  SURVEY 20:58 06 Nov 2009

I believe that I have found the problem! The computer had Zonealarm on it and comes up with Missing files: c:windows/system32/VSINIT.dll and VSDATA.dll. I believe these may be stopping Zonealarm?? I have these files on another computer but cannot transfer them over. Any ideas please?

  SURVEY 09:58 07 Nov 2009

Update - all works fine if I reset the system date to several months ago. As soon as I change the date and reboot, the computer reports that the aforementioned files are missing. In fact the files are there but must be corrupted and I cannot copy from another computer to the laptop.

I am sure that someone on the forum has the answer - you normally do!!

  Fruit Bat /\0/\ 10:03 07 Nov 2009

First scan for malware this problem is usually down to an infection.


1. Press Start and select Run
2. Type CMD and press Enter (or if you use Windows ME, type COMMAND)
3. Type regsvr32 vsinit.dll and press Enter

* To install the dll files, type: regsvr32 vsinit.dll
* To uninstall the dll files, type: regsvr32 -u vsinit.dll

4. In the end, you should receive a message saying that your file was successfully installed or uninstalled.

Do the same for Vsdata.dll

  SURVEY 11:06 22 Nov 2009

Hi Fruitbat. Now had the opportunity of looking at thsi computer again. After fllowing your suggestions, I dd not get a message saying file was successfully installed. rather I received one saying C:\Windows\ProgramFiles\Zone Lab\Zonealarm\zlclient.exe probably missing a necessary roor certificate; plus another saying \Windows32\Zona Labs\vsmon.exe probably missing a necessary root certificate. Any ideas now where I go from here

  SURVEY 11:58 22 Nov 2009

Ok - I think I have sorted the problems. I rewound the system date to April. Then I managed to uninstall Zonealarm (which I could not do whilst at the current date), that I guessed was at the root of the problems. Then reset the system date back to today and all seems to be OK.

So do I risk reinstalling a latest version of Zonealarm Firewall or just let my friend rely on the Windows one?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

Halloween Photoshop & Illustrator tutorials: 20 step-by-step guides to creating spook-tacular…

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?