Installshield Problem

  dogbreath1 07:50 15 Oct 2005
Locked

With the help of Taff36 and FE, I've just managed to complete the installation of a wifi network. click here for the relevent thread on the Networking Forum. You'll see that there is still a lingering problem in that on boot up, an Installshield window states...'Setup is preparing the Installshield setup which will guide you through the rest of the maintenance process'. I suspect that this could only be a legacy of either printer driver installation or wireless USB apadtor driver installation.

On a previous but similar occasion, I solved this using System Restore, but is there any other way of preventing Installshield from firing up coz it took quite a while to get things working and I'm trying to avoid driver reinstallation. Any ideas please??

  Forum Editor 08:35 15 Oct 2005

Simultaneously press the Ctrl Alt Delete keys and take a look at the running processes. See if any of the following appear:-

setup.exe

isetup.exe

ikernel.exe

msiexec.exe

idriver.exe

IsUninst.exe

IsUn16.exe

Uninst.exe

Uninst16.exe

Select each one and end it.

Then reboot.

The problem is arising because two instances of an installer routine were running at the same time - usually the result of starting a second installation routine before a previous one had completed.

  dogbreath1 10:40 15 Oct 2005

Thanks for that, I'll give it a try when I'm back in work on Sunday morning. Regards, db.

  dogbreath1 09:10 16 Oct 2005

Booted up this morning and Installshield appeared and ran the progress bar again. Launched Task Manager, but the nine processes listed by FE weren't present.

  Taff36 10:14 16 Oct 2005

Lets uninstall both the printer and the USB Wireless adapter. Do a cold boot not a restart with a two minute waiting time. Reinstall the printer driver first and check it all works.

Then cold boot again and install the adapter. Now do we get the same messages?

  dogbreath1 10:30 16 Oct 2005

Sounds like good advice, Taff36. Will try that when I'm back in work tomorrow. Cheers, db.

  dogbreath1 21:35 17 Oct 2005

Been a bit busy away from the pc today, will post back in next couple of days. Cheers, db.

  dogbreath1 09:08 18 Oct 2005

Have now achieved a clean install of the Brother printer software.

'Uninstalled' the DLink driver and tried a new install. Got the '1628 Failed to complete installation' error very early in the process. At this point there was no reference to DLink software in the Add/Remove Programs list, so I used RegCleaner to remove any remnants, disabled msiexec.exe in Task Manager, powered down then rebooted.

Then tried a fresh install of the DLink driver. Got the following error messages in quick succession:-

1. Error 1719. The Windows Installer Service could not be accessed. This can occur if you are running Windows in safe mode, or if Windows Installer is not correctly installed. Contact your support personnel for assistance.

2. 1628 Failed to complete installation.

3. String COMPANY_NAME was not found in string table

Any ideas please?

Regards, db.

  Taff36 06:45 19 Oct 2005

FE was right then! This looks useful click here Note that there are two different methods to resolve this - the second one looks promising.

  dogbreath1 07:47 19 Oct 2005

Yup, I agree. Thanks for the useful link. Hopefully will give this a try today but at latest tomorrow. Much obliged. Regards, db.

  dogbreath1 17:36 19 Oct 2005

Success, I think. Using Taff's link, I followed the second option as suggested. The Installer files that required renaming couldn't be accessed via the Command Prompt (for whatever reason), so I navigated to them using Windows Explorer and did the deed! After a reboot, the DLink software installed o.k. and after a bit of searching, the p.c. connected to the wireless network, evidenced by this post. Have not rebooted since, so I don't know what's going to happen next time, but I suspect that it will be o.k.. Thanks again to Taff36 and Forum Editor for your invaluable assistance. Regards, db.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Microsoft Paint set to die after 32 years

Mac power user tips and hidden tricks

Comment désactiver la saisie intuitive et paramétrer votre clavier ?