installing programmes or games as administrator

  richierich 18:32 06 Jul 2008
Locked

if i install a programme or game as administrator even though the icon on desktop is displayed on the desktop for other users too, some work and some do not. Is there a way to select so that other users with limited accounts can use them.
windows xp pro with service pack 3
thanks

  grey george 19:19 06 Jul 2008

Some programmes give you option at the install others don't seem to work to well with multi user logins. You may have to change each account to a full one then install on their log in and then put the account back to limited.

  Ditch999 23:09 06 Jul 2008

Open Windows Explorer, and then locate the file or folder for which you want to set permissions.
Right-click the file or folder, click Properties, and then click the Security tab.
Do one of the following:
To set permissions for a group or user that does not appear in the Group or user names box, click Add. Type the name of the group or user you want to set permissions for and then click OK.
To change or remove permissions from an existing group or user, click the name of the group or user.
Do one of the following:
To allow or deny a permission, in the Permissions for User or Group box, select the Allow or Deny check box.
To remove the group or user from the Group or user names box, click Remove.


To display the Security tab
Open Folder Options in Control Panel.
Click Start, and then click Control Panel.
Click Appearance and Themes, and then click Folder Options.
On the View tab, under Advanced settings, clear Use simple file sharing [Recommended].

  MarvintheAndroid 00:10 07 Jul 2008

Your problem is due to using Windows simple file sharing, which only gives you the option of setting up users as "limited" or "administrator". By going into control panel - folder options - view, you can de-select simple file sharing.

Then go into administrative tools - computer management - local users and groups, and add the necessary users to the Power Users group.

This should overcome most problems, but unfortunately there are still some programs which require administrator privileges to run them.

By the way, it is considered bad practice to use the administrator account for day-to-day functions. Far better to make your self a new user account with administrator privileges and use that instead.

Marv

  richierich 13:35 07 Jul 2008

have tried all the above but although the icon appears in each users desktop the game doesnt load, maybe its hust one of those cases mentioned.
thanks anyway

  Ditch999 16:02 07 Jul 2008

You need to go the the file the shortcut refers to eg C:\Program Files\iTunes\iTunes.exe and set the permissions on it, not the shortcut.

  richierich 16:43 07 Jul 2008

Ditch999, yes that is what I did but it doesnt work.

  Ditch999 19:26 07 Jul 2008

And have you given Full read/write access to all the Users you want to have it? ie tick all the boxes right to the bottom.
In the Security tab for the .exe file you could try clicking on Advanced and make sure the User is listed under Permissions and their Name. If you want everyone to have full access to it then click on Users then Edit and tick all the allow boxes.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 Hack Latest News: How Secure is your Wi-Fi?

Photoshop CC 2018 released with new Curvature Pen and better brush tools

Best kids apps for iPhone & iPad

Comment utiliser Twitter ?