Installing HP printer software

  Laser157 15:03 16 Jun 2004

I have just done a clean reinstall of Windows ME.

I installed the downloaded software from HP for my HP720c printer. This completed and the pronter works fine.

However each time Windows starts it still detects new hardware and tries to install drivers for it. In desperation I directed it to where I have saved the drivers and there is an inf. file. Windows seemed happy with that and said it had installed the hardware.

However on restart the same thing happens.

Any clues to help me resolve this?

  Megatyte 16:07 16 Jun 2004

Remove the printer in Device Manager and power off. Disconnect the printer. Turn the PC back on and run the HP setup.exe. Follow the prompts.


  Megatyte 16:09 16 Jun 2004

Sorry. That should be 'Remove the printer from Printers', not Device Manager.


  Laser157 16:50 16 Jun 2004

Thanks for responding Megatyte. I tried what you suggest but no success unfortunately. In fact the installation process asks you to have the printer connected, but I proceded without it and then reconnected after shutting down following the installation. Got the New Hardware splash but Windows couldn't find drivers itself. Directed to the folder on the HDD and it installed. On restart still finding new hardware!

In fact it's got worse now because I have a similar situation with a PCI communications device which is a Belkin Parallel/USB adapter for my Laser printer.

Both printers and the adapter function fine I just wish Windows would realise they are installed!!

  Laser157 17:39 16 Jun 2004

Update. I have got rid of the Belkin adapter problem by doing something like Megatyte suggested. HP problem remains though.

  Dorsai 18:20 16 Jun 2004

Unlikly, but could the download have got currupted? i would try downloading it a second time just in case...

  Laser157 22:09 16 Jun 2004

I used two different downloads with same result. The main difference with this printer is that it is not a USB device. It's the only one I have on the parallel port. However I have installed it several times before without this problem.

  Megatyte 01:57 17 Jun 2004

May not work, but it's worth a shot. Disconnect your printer and remove it from 'Printers'. Go to Device Manager (right click My Computer and select Properties) and remove thr Parallel port (You'll find it in Ports (COM & LPT), Printer Port (LPT1). Reboot your computer and let Windows re-install the port(you may need the Windows disk). Re-install the printer. And finally ..Good luck.


  Hedontownee 06:10 17 Jun 2004

When I had a problem with my Deskjet 670c I went to the HP web page ....there is a fault finder on there that interactively checks your printer is working correctly and is using the up to date drivers
Try that seemed to sort out the prob
Good luck

  Laser157 07:40 17 Jun 2004

Thanks to the night-shift for the further suggestions!

I have tried the HP diagnostic tool, but it does not detect the printer. This is probably because the system thinks it is not installed even though it works fine!

I may try the port reinstallation later on.

  Laser157 23:01 17 Jun 2004

I have tried the procedure suggested by Megatyte for reinstalling the LPT1 port and reinstalling the printer, but this has not resolved the problem. Also the Belkin adapter is again coming up as new hardware. As I said before both are installed and functioning. In Device manager under USB controllers there is a green? beside ' USB Printer Support'

Any more ideas? Thanks again for the above contributions.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

See mcbess's iconic style animated for Mercedes-Benz

iPhone X news: Release date, price, new features & specs

Black Friday 2017 : date, sites participants & bonnes affaires