Installed memory...broke clips,laptop wont boot

  restless 13:54 09 Jan 2009
Locked

Agh what I feared has happened.It was my first time installing memory but seeing as I had fitted a cd drive before reckoned it would be easy enough.

I stupidly didnt release pins so the plastic came away,I realised this so made sure to release them when removing from the second slot.New memory went in fine to both slots and managed to slide plastic back on to pins and although wasnt very secure I replaced the back,put in battery etc and laptop is dead.So removed back again and the pins hadnt held in place,one had come of and had been rattling about inside.Fear of doing more damage removed the memory leaving one slot empty and 1gb in the other.Laptop still wont boot...So at worst I fear laptop is dead or im hoping that it needs memory in the empty slot.

I guess im going to have to leave it in to get repaired?

  MAT ALAN 13:58 09 Jan 2009

I guess im going to have to leave it in to get repaired?

Good guess!!, cannot see any work around for damaged parts other than replacement, could be an expensive mistake.
Don't worry too much we have all been there...

  restless 14:16 09 Jan 2009

Don't worry too much we have all been there...

I feel sick its ridicilious,I mean its only a laptop! Kicking myself now for even trying it.Not to mention hubby who will take great delight in the "told you so".

One question...As the memory is installed correctly in one of the slots should it not be booting?

  MAT ALAN 14:19 09 Jan 2009

You may have disturbed some other cables might be worth another look to make sure everything is secure..

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

Illustrator Sylvain Tegroeg created thousands of intricate line drawings for the mobile game…

Best iPad buying guide 2017

Comment télécharger une application indisponible en France ?