Incomplete RAID set error,howto fix please?

  Chegs ® 00:20 22 Jul 2004
Locked

click here


Been at this for the last 24 hours constantly and now I'm asking you folks for assistance.


How can I repair it without going right back to square one,eg,delete RAID set,recreate it,partition it,install the OS.

Gigabyte GA-7VAXP Ultra mobo.

Athlon 2700 CPU

1.5Gb DDR RAM

2x120 Gb Maxtor SATA on Silicon Image controller

Pioneer DVD-RW

Liteon CD-RW

XP Home

  flyingpeterpan 03:33 22 Jul 2004

Have you tried upgraded your MOBO bios, I had the similar problem before, I did the bios upgrade to cure it. Good luck!

  Chegs ® 17:14 22 Jul 2004

I have the newest BIOS for the mobo (F6) I tried updated firmware for the HDD's and the Silicon Image controller,to cure this problem.I had them cfg'ed as striped array,when this error occured I had no option but to reinstall the OS again.Now I have them cfg'ed as mirrored,I can simply delete the RAID set and recreate them WITHOUT losing any data(but not always)

  flyingpeterpan 19:04 22 Jul 2004

Have you another Raid board to try your system with,it may be that your Raid controller is faulty.

  Dorsai 20:09 22 Jul 2004

It is being a bit of a bugger aint it. I managed to set up a raid array with little heartace, but it was an ATA100 one, not SATA. Persever though. It may just be being a cussed mother.

Could it be as simple as a dodgy HDD?

My secondary CD rom really upsets my PC if i leave a disk in it when i turn the PC off. It then blocks the boot process for about 5 mins while it tries to check if there is a disk in it or not. Boot up with no disk and it is fine.

I spent days once, eons ago, trying to get the mouse working on my then new Win95 system after i crossed my legs and knocked the serial socket out of the back of the PC. it fianlly started working and worked fine till the mouse broke. then days spent trying to get the new one to work. And it should have been as simple as to plug it back in.

  Chegs ® 00:51 23 Jul 2004

Well,here I am again.Its still being an absolute sod.I cannot get it to install to an NTFS partition,I had to format C: as FAT32.The git still runs a disc check every reboot.It claims that an empty partition has files in use by windows so cannot run chkdsk command,which I asked it to as it says there are corrupted files in it.I am off to bed,if the swine still acts up tommorow,then I'm going back to an IDE drive with the SATA's as huge storage!

Disc checking earlier refused to run,just sat on 0% for an hour.The hdd tester still says these hdd's are in good order.

I arrived on here approx an hour ago,typed this reply but the git locked up completely before I had chance to post responses.

I want to convert the C: partition to ntfs,but last time I tried the convert C: \fs.ntfs it crashed before it had a chance to run.

  Chegs ® 10:30 23 Jul 2004

I also get scsiport.sys/Si3112r.sys crashing XP to BSOD.One of the partitions I formatted yesterday has "forgotten" its name,dskchk STILL runs every reboot.WinUpdates wont install until I get a clean reboot.I have had so many apps cause problems(InCD was the latest)and it keeps booting upto an icon/taskbar free desktop.I tried to restart explorer.exe via task manager,but again it refused.I expect it to crash and refuse to restart sooner rather than later,so it looks like I'm gonna be disappearing for the rest of today as I fight to reinstall XP yet again!

  flyingpeterpan 12:53 23 Jul 2004

(sorry, I don't know how to do the fancy R in a circle,a laugh)
Appreciate your consistance with your PC,but RAID is very sensitive, I have 4 PC in a network,all without any partitions,3 of them in RAID 10(4 HDD in mirrored/striped/Sil 3114r) & 1 in RAID 1(2 hdd /mirrored/Promise).When I set up the 1st RAID 10 PC, I had the similar problem,"incompleted raid set" messages always came up, and I ended up going round in a circle for weeks,finally I gave up and tried the whole system in a spare board with similar spec but different CPU, this time it worked and gave me time to sort out the 1st board by upgrading the MOBO bios eventually.Anyway the working RAID 10 PC was still a bit unstable at first,it kept rebuilding one of the channels,and refused to shut down if it was on for some time, I had to do it manually,gradually extended to keep rebuilding 2 of the channels,and finally it crashed and dropped these 2 channels, but the PC still worked(on RAID 0,that's the beauty of RAID 10,as long as there are min.2 hdds left,it still works)And I couldn't get these 2 hdds back to the RAID set as though they were abandoned, I had no choice but rebuilt the RAID set and reinstalled the OS although the PC still worked. This time I changed the RAM to branded ones and had a go, BINGO, it worked ever since and led to the building of the rest of PCs. Correct me if I am wrong, you said you confg'ed mirror raid on your PC,and you can delete the raid set and rebuild it with all the datas, isn't it if you delete the Raid set, all the datas will be gone? Can you try it with less RAM? By the look of all the difficulties you trying to install OS, your raid controller is very unstable, even though you are successful this time,I am sure it will come back to haunt you,anyway keep it up, have some fun ,take the challenge and you'll love the feeling of satisfation at the end. Peter

  Chegs ® 13:06 23 Jul 2004

I removed 2 sticks yesterday,got XP reinstalled with just 512Mbs.All was working fine until I updated the OS.The other RAM sticks I replaced last night,as it made not a scrap of difference to the PC's stability.I have finally managed to run SFC /SCANNOW without it locking up,but CHKDSK still keeps running on reboots and only ever completes one out of five reboots.The Incomplete RAID messages appear if the CHKDSK fails and I need to reset the PC,but as I said,if I delete the RAID set,then recreate it(as mirrored)the "dropped" hdd returns(fortunately without any apparent data loss)So far XP's managed to stay working for nearly 8 hours now. :-)

  Chegs ® 16:29 23 Jul 2004

I have just finished trying to reinstall XP onto the RAID setup,XP couldn't "see" one of the SATA drives and mid install one hdd started emitting a loud clicking.Ran the tester app and again one hdd refused read/write.I removed it,installed the IDE hdd,wiped linux from it and installed XP onto that.The Si controller was showing a SATA as "Not Found" so it looks like the SATA that I have often suspected was faulty(from new)actually is.I'm off now to price up a replacement 120Gb SATA.

  flyingpeterpan 16:41 23 Jul 2004

Great to hear that you can get to the root of the problem,hope you can sort it out soon,while I keep an watchful eye on all my systems and let my kids do all kinds of punishments (works and games and internet)to them.:-)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Lightwell software lets you create mobile apps without using code

Best value Mac: Which is the best £1249 Mac to buy

Comment désactiver les programmes qui s'exécutent au démarrage de Windows 10 ?