Improperly Dismounted Partition

  lermontov 19:58 25 Jun 2005

This occured when a System Restore hung and the computer had to be forced to restart. The dreaded Ctrl, Alt, Delete.

None of the options to run the drive tried - Safe Mode, Safe Mode with Dos Prompt, Last Known good Configuration etc. - NONE of these worked.

I have tried to access the Restore facility in Set Up (needed to download a setup prog to run from floppies because the admininstrator password would not be recognized using the Restore CD from the manufacturer).

Doing so didn't much help. It gave two options, neither of which worked. One gave you only the option of reinstalling XP Home with the loss of all the data. NO repair option came up.

I have asked this question previously but have had no joy.

Is the only option left to format a new drive, partition it, image the old one, back up, reformat the old drive, partition that then duplicate the vital files back onto it?

I understand the notion but this is way beyond my abilities. Do not have the money to take it to a shop and don't trust them anyway...'Oops, sorry, had no option but to reformat the whole thing' these stories are all too common and not merely apocryphal.

Is there NO way of recovering the unbootable drive? Of repairing it with commands and known software??

P.S. Partition Magic can diagnose the problem but it cannot fix it.

None of the suggestions in my previous post]

click here

Have solved the problem for me.

  bremner 20:07 25 Jun 2005

Googled and found this:click here which might help.

Partition Improperly Dismounted

I poked carefully at the computer with various tools attempting at all costs not to alter any data written to the disk. Using Linux (Knoppix stand alone bootable CD) I was able to view the partition and see that all my data was just fine. I tried Partition Magic and it reported the error message "partition improperly dismounted". While Partition Magic is able to cure many problems with partitions it was unable to fix this problem by itself. Searching for that term on the net I discovered the cure.

The fix was to run check disk (CHKDSK) to fix the way the file system was laid out. Specifically, "CHKDSK /p" was the command. However, a plain CHKDSK revealed a single bad sector so I actually ran "CHKDSK /r" which will fix the sector problem as well as the partition problem. Executing this command properly set the flags for the partition and file system so that it could be mounted and booted from once again.

But, the system was dead so how to run CHKDSK? That turned out to be very easy. Just boot from the Windows XP install disk. It allows for a console from which many common tools including CHKDSK are available to run from the CD.

I was back up and running in fairly easy order. My time invested in the actual fix was probably 5 minutes. However the computer took an hour or so to carry out that fix using CHKDSK. But once it was done I could boot with no problems.

  lermontov 21:45 25 Jun 2005

Thanks Bremner. I followed these instructions (using the start up set of floppies to bypass the unrecognized adminsitrator password problem) then chose the 'R' repair option.

This gave the C: prompt and I typed in as instructed 'CHKDSK/r' but all I got was:

'AUTOCHK.EXE could not be located in either the startup directory or the CD Rom Drive.

Type the full path (including drive letter) for the location of AUTOCHK.EXE'

What do I do? Do I put in the Recovery CD (not full XP Home but the Evesham Recovery disc that came with the PC years ago)?

Or can someone explain to me what I have to type *exactly* to execute the command:

'Type the full path (including drive letter) for the location of AUTOCHK.EXE' ???

Any prompt help gratefully recieved.

  bremner 22:07 25 Jun 2005

The path for autochk.exe is C:\windows\system32 so at the command prompt type:

  lermontov 22:24 25 Jun 2005

Thanks, just tried that bremner and it still doesn't recognize the command.

In fact, it points me to the HELP menu which I type 'HELP' after the C:/ to look at the options it lists and even when typing them in it still doesn;t recognize the command.

Could it be that my hard drive is for some reason NOT labelled 'C' and the command just cannot be linked up to it?

  woodchip 22:35 25 Jun 2005

If it cannot boot the disc it will not find files on it in DOS. Download TestDisk NT version for Win2000 and XP from click here

  lermontov 22:39 25 Jun 2005

When I get past the 'R' option (the option to Repair) when going into the setup and then I'm asked which drive i want to repair - it only gives one option:

1) C:\windows

Fine I type in 1 then I;m asked for my admin password. I hit Enter (having booted up from a set of floppies to circumvent the admin password not being recognized. Fine, this gives me prompt


Now what am I supposed to do? bremner's suggestions (fopr which I am grateful bremner) didn't work.

Any attempts get the message:

'AUTOCHK.EXE could not be located in either the startup directory or the CD Rom Drive.

Type the full path (including drive letter) for the location of AUTOCHK.EXE'

Can nobody out there help or has had the same problem?

Why won't it recognize the commands?????

  lermontov 22:56 25 Jun 2005

Thanks woodchip. I've downloaded the zip file and will put it onto a floppy. Then give it a try. But when I'm fresh in the morning. I'm frayed, fragged, dazed and confused now. Thanks for the input so far both of you.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

See mcbess's iconic style animated for Mercedes-Benz

iPhone X news: Release date, price, new features & specs

Black Friday 2017 : date, sites participants & bonnes affaires