iMovie problem with Snow Leopard.

  dan1611 19:03 19 Jan 2011
Locked

Hi I have an Apple Macbook 2ghz Core Duo 2GB Memory 80GB HD it has Snow eopard installed. We also have iLife 09. All the applications work on it other than when we try and use iMovie, when it says "you can't use this version of the application iMovie with this version of Mac OS X. You have iMovie 7.0.

Can anyone tell me what if anything I can do to use it or do I need to upgrade to something else.Thanks

  bremner 19:39 19 Jan 2011

iMovie 08 v 7.0 and 7.1 will not run on SL

You must update it to 7.1.4 by running "Software Update" from the Apple Symbol top left

  bremner 19:41 19 Jan 2011

Solutions to Apple problems can often be found at the Apple Support site click here

  dan1611 21:13 19 Jan 2011

Thanks, all working perfectly, thanks.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?