If viruses were money, I'd be rich! What to do?

  Philbert 05:51 03 Dec 2005

I am not sure what is going on or what to do about it. I’ve tried everything I know to try and have learned a couple of new tricks that didn’t help.
I’m using WinXP on a Dell Dimension. I removed a virus W32.chod from my PC with NOD32 (or at least it said it removed it). I had Symantec AV 2005 when I got the virus. Symantec AV started issuing notices that my subscription had expired. In fact I have 9 months more on it. I couldn’t get through to the Symantec website to re-register or get help. I quickly found that I couldn’t get to the Panda AV website or Kaspersky or many other security websites. I can’t download Microsoft updates and patches. I was able to download the trial version of NOD32. When run in safemode it said it removed a variant of W32.chod. The subdirectory, and file are gone, but registry references to windows\system32\xxxxxx\csrss.exe remained (where xxxxx was a string of random characters). Using regedit I deleted the keys referring to the xxxxxxx\csrss.exe file. But the problems persist! When my browser (IE and Firefox 1.5) is able to get to a site it crawls the whole way there. I have been able to scan with Trend Micro, Microsoft’s malware program, and a2 and they find nothing. What do I do now?
Phil - Wisconsin, U.S.A.

  spud22 06:37 03 Dec 2005

have you tried restoring the system to an earkier date then run stinger from this link click here it finds most viruses and trojans.If that doesnt work you may have to format your hard drive

  Forum Editor 08:13 03 Dec 2005

is a nasty mass-mailing worm that spreads via MS Messenger.

You can remove it manually if you are up for a session of registry editing
click here to find out how to do it.

  Major Disaster 10:36 03 Dec 2005

Do you know excatly what variant of W32.chod it was?

  Philbert 18:41 04 Dec 2005

Stinger found Qhosts.apd trojan.
I can now go to any AV test site I want. I also was able to download MicroSoft's new OneCare Live Beta and update XP patches. OneCare Live found nothing.
I started going through the registry editing I was directed to, but wasn't finding the entries the instructions referred to. Could it be a different variant? Could It be I've had (or have) a couple of viruses (worms,trojans . . .).
The things I was experiencing doesn't match with the description of the Qhosts.apd trojan.
I don't know that any more action is needed, but I still don't understand what was going on.
Thank you for the help.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

Photoshop CC 2018 released with new Curvature Pen and better brush tools

Camera tips to take better iPhone photos

Les meilleures applications de covoiturage 2017