ie7 right click disabled

  andym99 12:37 06 Nov 2007

Hello..... recently I have lost the ability to right click while using ie7. absolutely nothing happens. except on the toolbar, I still get the toolbar context menu there. I still get the context menu in other applications.

Also favourites/links/google searches/etc now open in the same tab rather than in a new tab, even though that is still the option selected under tabs in internet options.

I have run a spybot scan and an avg virus scan and have now downloaded and re-installed ie7. the problem is still there.

would appreciate any help.........

  birdface 12:58 06 Nov 2007

Have you tried Control panel.Mouse.Hardware,And press troubleshoot.Or while in there press properties,Driver ,and try and up-date the driver.Also does it work Ok on Firefox or any other browser.

  The F1 Help Key 13:04 06 Nov 2007

how to Enable Right Click!!

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions]

a virus have done this to your PC

how to disable Right Click!!

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions]

you notice the virus have change the 0 in to 1.

hope this will help u dear

  andym99 13:24 06 Nov 2007

thanks F1.... there are no values under Internet Explorer/Restrictions just.....
ab(Default) REG_SZ Data field is blank.

I added the value you posted above and reststarted ie but still no right click..... (I am not really familiar with regedit as you may have guessed....;-)

  The F1 Help Key 13:50 06 Nov 2007

create a new key and name it ..restrictions and fired the value....ok i can see u are not likely wite regedit...give me 3 hours i will find a software that will automatically bring ur rightclick too i get this problem long long ago....stay connected

  The F1 Help Key 14:16 06 Nov 2007

Check this link...a program that will edit your right click menu...then u mark the tick on internet explorer

click here

  andym99 15:52 06 Nov 2007

thanks f1.... I downloaded and run the programme.... still no joy.... but after hunting around on I downloaded and run registry cleaner from abexo and right click option has returned :)

although my mouse gestures have not returned.....

thanks for your help

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Microsoft Surface Book 2 hands-on review – bigger and 5x faster

Best kids apps for iPhone & iPad

Que faire si son iPhone ou iPad est tombé dans de l'eau ?