IE7 has removed Opera as prefered Browser

  Ancient Learner 21:07 20 Jan 2007
Locked

After a long winded repair job, I have had to update Windows with many items including IE7.

IE7 works fine, but now it seems to have caused my Opera to not be my prefered browser. IE when I click a lnk it goes ia IE7 and not Opera as it did previously and which I want to happen again.

I can't find anything to fix it myself. How do I do it?

  Stuartli 22:28 20 Jan 2007

Try Start>Set Program Access and Defaults.

Configure Opera as the default browser. It may take two or three attempts over time as the Microsoft products tend to try and hog the limelight...:-)

  Ancient Learner 17:28 21 Jan 2007

Thanks Stuartli.
I've tried a few times, but it is stubbornly not changing.

Can I check that I am doing it correctly.

I open the Start>Set Program Access and Defaults. Then open Custom, and find that the 'use my current web browser is dotted. No mention of Opera! So I can only click OK.

This seems insufficient, but what else should I do?

  Ancient Learner 18:38 21 Jan 2007

Got it.
Open Opera>Tools>Preferences>Advanced>Program. Tick 'Check if Opera is Default Browser on Start up.
Next time Opera is Started, answer question with 'Yes'

And that does work fine.

  Stuartli 20:09 21 Jan 2007

Glad you've sorted it. In my case I can configure Firefox as the Default.

  Ancient Learner 21:52 21 Jan 2007

Stuartli. Many thanks, I much appreciate your interest.
Best Wishes.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

Halloween Photoshop & Illustrator tutorials: 20 step-by-step guides to creating spook-tacular…

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?