IE7 changes Internet shortcut icons on the fly.

  Batch 17:58 22 Nov 2006
Locked

Since installing IE7, I've found that some of the icons of my Internet Shortcuts are getting changed on the fly.

Not only is it annoying that Microsoft allows websites to change things that I have specifically set-up (i.e. the icons), but I have the problem that, on the Quick Launch for example, several shortcuts now have the same icon ('cos they point to different parts of the same website). It's no good just changing them back to what I had before as the next time I visit the site they just get overwritten again.

Is there a setting somewhere that I can use to prevent my choice of icon being overriddden?

  Batch 09:16 23 Nov 2006

bump

  terryf 09:22 23 Nov 2006

Use FF 2.0 instead :-)

  Gongoozler 09:27 23 Nov 2006

My understanding is that the shortcut icons are included in cookies, so the only way to stop them changing is to disallow cookies. I think FF does the same.

  Gongoozler 09:38 23 Nov 2006

This site click here explaining how to make a favorites icon for a website says that it's in the cache (temporary internet files), so that's where it gets updated.

  Gongoozler 09:44 23 Nov 2006

More research. In Firefox favicons can be disallowed click here

  Batch 11:29 23 Nov 2006

Thanks for the info.

I would have thought that clearing out the cache (I've run ccleaner and used all the delete options in IE7 and rebooted) should "lose" the favicons and reset the icons to my selection (or some default), but it doesn't.

So although favicons may be the source, the info must get stored elsewhere.

I've tried searching through the registry for any related info. but can't see anything obvious.

  PC Usah 16:07 23 Nov 2006

Personally prefer shortcut icons have their own identity - the 'e' symbol as standard simply gets boring.

  VoG II 16:11 23 Nov 2006

You could try FavOrg 1.2 click here but I'm not sure if it will work the same in IE7 which I believe handles Favicons differently to IE6.

  Coff 17:22 23 Nov 2006

I got this method to work.

Right click your Internet Shortcut and give it the icon you want and click OK and then OK again ie. come right out of the right click window.

Right click the shortcut again and click on the General tab and tick the "Read-only" box. Click OK.

  Batch 17:28 24 Nov 2006

That seems to have done the trick!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

InVision Studio takes on Adobe XD and Sketch

iPhone X news: Release date, price, new features & specs

Comment transformer un iPhone en borne Wi-Fi ?