ie7 broken links - oops that link appears to be br

  awest3 09:57 26 Mar 2009
Locked

I'm getting a lot of broken links, a lot from google (in fact most of their sponsored links), some email links won't work (tesco) but others as well. I downloaded IE8 but uninstalled it when it proved troublesome esp with PC Advisor pages and was very slow. If I turn off Google's 'provide suggestions on navigation errors' I still get page not found from the browser but if I type the site in it works perfectly. any ideas..?

Al

  birdface 10:01 26 Mar 2009

With PCA pages you have to go to Tools and tick compatibility View.it works better with that ticked.

  birdface 11:05 26 Mar 2009

You could try this.Start.Run.type in, cmd then press .Ok.In command prompt type. ipconfig /flushdns small space between ipconfig and forward slash or it will not work.Ok.it should tell you dns cache has been flushed if so reboot the computer and see if it works any better.

  awest3 15:49 26 Mar 2009

sorry should have mentioned..Vista Sp1, dell insipron 530s,4 gb ram...

  awest3 15:55 26 Mar 2009

tried the flush but no joy..I notice that google sponsored links at the top of the page and on the right of the page do not work...is it maybe a google issue..?

  awest3 16:19 26 Mar 2009

trying ie8 again...the compatability thing works for PCA(Thanks) , but I still have the broken pages problem....

  awest3 19:01 28 Mar 2009

went back to IE7...mostly ok but I still cant open Google sponsored links...any Ideas....?

  awest3 12:53 14 Apr 2009

bump...! still got the problem

  birdface 13:39 14 Apr 2009

[I notice that google sponsored links at the top of the page and on the right of the page do not work...is it maybe a google issue..?]
have you clicked on the down arrow at the end of the search button.And made sure Google is the default web provider or just add whatever provider that you
need.

Also maybe try Firefox and see if you get on any better.

  awest3 09:30 15 Apr 2009

I thought it must be a setting in Vista somewhere, as it does not happen on either of my two XP machines. It also happens when there are links within a page I am viewing. I have to type in the url which then works ok..

I use ie7...I've run superantispyware and malwarebytes just in case...also CC and a reg cleaner...no change

Al

  rawprawn 09:41 15 Apr 2009

Have a look here Tools> Internet Options> Advanced> Browsing> Tick "Enable third party browser extensions"

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Les meilleures tablettes 2017