IDE/USB cable defective?

  jack 12:19 08 May 2007
Locked

I purchased such a cable in M arch as I have a collection of salvaged HDD onto which I would like to put stuff for storage.
At first it worked well.
But in the past weeks I cannot get a disk to come onto the system at all.
I also have two caddy drives- so to check out a potential problem a stripped out a caddy ans plugged up each of the 'salvaged bare drives' in turn.
They all worked.
Going back to the cable however they do not.
I have one plugged in now as I write.
It does not show at all in 'My Computer' or in Disk Management
The Red indicator is showing and the disk is running from the external power supply.
I also get the odd clatter of a read process - but no sign of any activity in the computer.
I have E-mailed mailed the Tech Support at the supplier and am awaiting their response.
Any ideas from here folk?

  MAJ 12:55 08 May 2007

Usually, they either work or they don't, jack. I have one myself and use it for testing old drives (saves installing them). If the drives are otherwise working okay, then it's probably a fault with the cable, maybe a faulty connection to the ide interface on the drive.

  wee eddie 13:22 08 May 2007

Maybe a pin or socket is damaged.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone