IBM T22 Laptop won't start

  xoc 21:44 23 Sep 2008
Locked

My Laptop won't start up.
Battery is fully charged.
If I click start button without charger connected, I get a subdued click and start light flashes momentarily, but no progreesion to start.
If I press start button with charger connected I get nothing.
The symptoms of a problem with startup have been evident in hindsight, when there were difficulties in starting and shutting down, but I persisted and gotit to start, until today when there was just no response.
Any solutions welcome.

  woodchip 21:56 23 Sep 2008

Try with the Battery Removed, just have mains plugged in

  woodchip 21:57 23 Sep 2008

Battery may be fully charged as it says but it may not power the Laptop. They develop internal faults

  xoc 22:06 23 Sep 2008

Thanks but have tried with battery removed and every obvious trick in the book, to no avail.

  woodchip 23:50 23 Sep 2008

have you tried with the Hard Drive removed. if it boots to BIOS then the drive is faulty or corrupt

  xoc 00:41 24 Sep 2008

Yes I have tried that! have also tried a previously used HD, but only get a brief flash from the HD light, but no startup!
I Feel it must be the system board, so may have to buy a replacement laptop, as can probably buy one cheaper than a system board.
Thanks for trying to help.

  xoc 10:42 24 Sep 2008

Thanks to all who tried to solve this problem!
I am pleased to advise that it has been resolved another forum, and I am pasting the solution here, just in case others have the same problem.

Quote:
check output of your AC adapter. Replace the adapter as necessary. Use genuine/original IBM adapters for lesser headache.

"Many thanks for that tip!
I should have explained that I have two Thinkpads, one an old 570 and the T22, and I as it turns out I was using the charger from the old 570!!
When I changed to the correct one, I noticed that the battery charge light came on, but only got a faint click sound on pressing the start button, but I left it connected, went to collect my morning paper, and when I got back, tried the start button again and hey presto!! I was back in business!"

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?