I can't start the SuperFetch service in Windows 7

  Meddi1980 20:11 09 Mar 2011
Locked

My Windows 7 Home 64-bit boot has become slowly, so I suspect it's because SuperFetch service won't start... I can't start it myself, nor will it start automatically. These are the steps I've already taken:

- I've set the values for reg entries of "EnableSuperfetch" and "EnablePrefetcher" to "1",

- I deleted the contents of the "prefetch"-folder in C:\windows,

- I've done the "sfc /scannow" test using Command Prompt. The command created a log file called CBS with a plethora of information which I don't understand... There ARE some "errors" in there...


And still it won't start. It does however start ONCE after I delete the contents of the "prefetch"-folder, but than I'd have to delete the folder everytime and that beats the whole purpose. Please give me some suggestions, thank you.

  Fruit Bat /\0/\ 21:42 09 Mar 2011

1. Click the Start orb and type REGEDIT in the Start Search area.

2. Open the Registry Editor.

3. Click the plus sign next to HKEY_LOCAL_MACHINE
then SYSTEM
then CurrentControlSet
then Control
then Session Manager
then MemoryManagement
then click PrefetchParameters

4. On the right side, double-click on EnableSuperfetch

5. Give it one of the following values:

0 to disable Superfetch
1 to enable prefetching when program is launched
2 to enable boot prefetching
3 to enable prefectching of everything

Click OK.

6. Close the Registry Editor.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?