I can't "Safely Remove Hardware"

  pj123 13:56 14 Nov 2007
Locked

Every time I try to remove hardware I get a message:

"The device Generic Volume cannot be stopped right now. Try stopping the device again later."

I don't want to try again later, I want to remove it now so that I can put another device in.

The way I do it now is to power down the PC change the device and then reboot.

If I take no notice of the message and just unplug it anyway, the computer crashes, so I have to reboot as well.

  xania 14:01 14 Nov 2007

When I use an external device, I get this message if data is still being transferred or any of the files on the device is open or even being viewed in Windows Explorer. You could damage your device or the data on it if you remove the device before it is released. If this problem occurs for more than one device, I would think this points to a corrupt USB or similar file in Windows, and your best bet is to try to repair Windows.

  100andthirty 14:02 14 Nov 2007

What is it?

I have a Maxtor one touch USB Hard Drive. It has a little driver on the computer that responds when the button on the front of the PC was pressed. It used to exhibit this issue. (although not crashing!) Since I had Windows re-installed, I haven't installed the on-touch driver and it doesn't exhibit this issue any more.

Normally this message will appear if you have any windows or applications open that access your external device.

  aine 21:07 14 Nov 2007

Have you tried to stop the device in safe mode, you can the activate your safely remove hardware, the add hardware wizard may tell you it is in use, when it is not, in the normal mode. good luck Aine

  daba 00:12 15 Nov 2007

Perhaps preaching to the converted, but....

I assume you are navigating away from the device's files in explorer, or whatever other program you might be using, to view/access the files on the device ? Then you ought to be able to stop the device.....

just a thought..

  pj123 12:17 15 Nov 2007

I have 2 IDE hard drives. 1 x 250gb which I use for video capture and editing. (I am transferring all my Beta/VHS Tapes to DVD).

1 x 160gb which I use to backup all my data files/photos etc.

The error occurs when I try to switch the drives.

Yes, I do navigate away from the drive before attempting to remove it. There has been no activity on the drive (G:) at all today but I still get the error when trying to remove it.

As far as I know nothing is actually pointing to it. The programs I use for video capture/editing are all inactive. There should be nothing wanting to access this drive.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

See mcbess's iconic style animated for Mercedes-Benz

iPhone X news: Release date, price, new features & specs

Black Friday 2017 : date, sites participants & bonnes affaires