HP7946 Sound Problem

  madmaxollie 08:36 27 Dec 2005
Locked

I hope you can help.

I have an HP7946 PC with polk audio speakers. These are supposed to be driven by a small amplifier which is mounted in the rear of the base unit.

Following a severe disk crash, I've had to reload the machine completely (XP SP2).

Un-amplified Sound comes out of the green connector, but nothing comes oot of the orange connector.

Now heres the funny thing, If I use a Knoppix Boot CD, Linux works OK through the Orange connector. (I guess this means that all the hardware works and is all wired correctly).

I've been onto HP Help online, and following a soccer games worth of chat, they suggested I buy some amplified speakers and plug them into the Green Socket. Whilst this does work, I've not really been too satified with that solution.

Any Ideas?

Martin.

  SG Atlantis® 08:54 27 Dec 2005

have you checked hp for all driver updates?

  SG Atlantis® 08:55 27 Dec 2005
  ICF 08:58 27 Dec 2005

Have you loaded your motherboard drivers?

  SG Atlantis® 08:58 27 Dec 2005

also click here

  madmaxollie 10:07 27 Dec 2005

I beleive I have all the latest Motherboard drivers loaded. All the other devices shown seem to work OK. Sound does come out of the green socket.

On the HP website there is nothing specific about Sound Drivers.

However, I do not have the "Multi-channel Sound Manager" available as a program/setup option.
(See click here ) Section "Configuring on-board audio (AC97)"

Could this be a clue?

Martin.

  SG Atlantis® 11:33 27 Dec 2005

click here

download the third one in the first table and install it.

  madmaxollie 13:19 27 Dec 2005

Thanks to you for your help - I now have my sound working again.

The Realtek drivers sorted it out.
The VIA and XP default drivers seemingly did not.

This is my first day of using PCAdvisor, and the support allowed a problem to be fixed; the same problem has been bugging me for some months.

Thanks again.

Martin.

  SG Atlantis® 22:49 27 Dec 2005

Glad to have helped.

Thanks for the email but it wasn't necessary ;)

Any more problems post them in the relevant forum and the kind folk here will jump at the chance to resolve them for you.

SG A

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Les meilleures tablettes 2017