HP5151 printer problems

  GrandadW 13:00 22 Jul 2007
Locked

My HP deskjet 5151 printer has suddenly stopped printing documents. It will print the test page, however. Re-installing the software makes no difference and installation on a different computer produces the same result even when the latest driver from HP's website is used. A Ubuntu Linux printer recognised the printer, but wouldn't print either.

Is it possible to update the printer's firmware and, if so, how does one go about it?

GrandadW

  FreeCell 15:14 22 Jul 2007

Update of firmware
click here

However what makes you think that this will resolve your problem?

There is usually a hard and soft reset with HP printers involving pressing certain keys and re-installing the power connector. May be worth investigating for your HP5151 and giving that a try to reset any printer issue.

  GrandadW 18:22 22 Jul 2007

Thanks FreeCell, but I cannot find any reference in the setup guides or on the CD provided with the printer about hard or soft reset. Nothing came from my Google attempts. If anyone else knows more about this, I'd appreciate hearing from you.

GrandadW

  FreeCell 18:56 22 Jul 2007

Try the following cut and pasted from different pages of HP Support site:

Hard reset the printer
Turn the power off. Remove the power cable and the data cable from the unit.
Connect the power cable directly to a wall outlet.
Reconnect the power cable to the unit and turn the power on.

then (from 500 series page)

Wait for approximately one minute and then print a self-test by pressing and holding the Power button and pressing the Resume button four times. Release the Power button. The self-test page should print.

  FreeCell 18:56 22 Jul 2007

Sorry that should have been 5000 series page not 500.

  GrandadW 00:24 24 Jul 2007

Tried your latest suggestion FreeCell without any change to the symptoms i.e. prints a test page OK, but any other print command produces a blank page. It will not install on any other computer now at all so time to admit defeat, I think. Thanks.

  I am Spartacus 00:31 24 Jul 2007

Have you tried a different printer cable?

  GrandadW 19:22 24 Jul 2007

I have tried a different usb cable without any effect. I also assumed that as the printer wouldn't print text from Word, Wordpad, Notepad or Open Office Writer, that was conclusive. Just when I was about to give up however, a family member has suggested trying to print pictures. It did (both jpeg and tif) without hesitation! It still won't print text afterwards though.

  FreeCell 19:48 24 Jul 2007

Similar problem seen on internet sire, where graphics print but not text. Try changing text in Word to red and seeing if that works. If so problem is most likely blocked/faulty print heads on your black cartridge.

  GrandadW 22:05 26 Jul 2007

Changing text colour to red or blue did indeed allow it to print text in those colours. Cleaning the head of the black colour cartridge made no difference ie. would not print again as soon as the text colour was returned to black. Replacing the black cartridge with a new one also made no difference. It appears that there is a firmware or an electrical fault which means that the information is not reaching the black cartridge.

  FreeCell 14:38 27 Jul 2007

Have you checked the contacts for the black cartridge in the printer and cleaned them? Try rubbing with a pencil rubber or using a little isopropyl cleaner or switch cleaner.

Have the cartridges you have used been refilled ones as opposed to HP genuine cartridges? Damaged cartridge may I suppose cause electric short circuit on print electronics. This would need a good diagnostic engineer to find.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?