HP PSC 2170 will not print

  billy-joe 10:32 18 Mar 2006

I am running windows xp pro, i have an msi K8N Neo Platinum mainboard and am using a HP PSC 2170 multifunction device. The printer will not print. I can use the scanner and the card reader without a problem and it will also function as a standalone copier and print okay but will not print from the PC through any application at all not even it's own test page. When i attempt to print something it pulls a sheet of paper through, lines it up to print and then simply feeds it through blank. I have replaced the usb cable, i have uninstalled and re-installed the software several times but still have the same issue. I have installed it on another computer on my network and it functions perfectly, i can also print from my main machine to it using it as a network printer on another PC, this works fine but i need it installing on my main PC to be able to scan in images and use the card reader. The device did originally work fine for 12 months till about six months ago, i've tried everything i can think of. Just wondering if anyone has come up against a similar problem or knows of a solution. Thanks.

  TOPCAT® 11:46 18 Mar 2006

for your PSC2170 all in one printer. I hope this will help resolve the problem. TC.

click here

  billy-joe 14:45 18 Mar 2006

Thanks TOPCAT. I have tried all the possible solutions on the HP site but am still having the same issue, it seems to be a communication issue between the PC and the printer. I have however found that the only printout i can acheive is by using the HP Toolbox utility, if i try to print a test or diagnostic page from the HP toolbox it does print but any other application including printing a test page from printer properties will just not print. I have removed all usb devices and uninstalled all entries from device manager and had them re-install but no joy.

  Totally-braindead 14:52 18 Mar 2006

The only suggestion I have is to try another port if you haven't already done so. Have you any other USB devices that you can use to test the ports. I have to agree with you in that it appear to be a fault with the USB on the PC.
I must admit I haven't tried any networking myself and wonder if that could have something to do with it, I don't suppose you've made any alterations to your network about the time the printer failed? Are you logged on as the administrator when you reinstall the printer software?

  billy-joe 15:09 18 Mar 2006

Thanks TB but i have tried all the usb sockets and i have the same issue with them all but i have other devices that work fine in those sockets. all the alterations i make are done as the admin. I wish i could think of what i had done just prior to the printer failing but i cannot think of anything, it probably is something i've done but i just can't figure it out. thanks for the help guys.

  TOPCAT® 23:12 18 Mar 2006

As a last resort(??) have you tried HP's web based diagnostics tool? Reading the blurb: "This tool will automatically detect your product, operating system, and connection status. This tool does not access your personal data." Hopefully, it will go further and indicate the problem for you.

Can't suggest anything else except for contacting HP themselves. TC.

click here

  De Marcus™ 23:16 18 Mar 2006

If you get no joy from the above suggestions try using the interactive help, you should get a technician online live to have a chat with, I found them to be very helpful when I was having problems with an old printer some time ago.

click here

  billy-joe 00:03 19 Mar 2006

Thanks guys, i tried the diagnostic tool but it isn't reporting any error. i tried contacting the online tehnician support but the techniciain i was in touch with called "baldwin" cut me off when i gave him my uk phone number, is it only available to usa residents??

thanks for trying guys but this seems to have beaten me.

  De Marcus™ 10:41 19 Mar 2006

Did you change the country option box to united kingdom?

  De Marcus™ 10:41 19 Mar 2006

sorry 'United Kingdom'.

  billy-joe 11:05 19 Mar 2006

Yes DM i had which is why i thought it strange. He said he needed my number to see if he could find me on the system, then when i submitted it he cut me off.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment utiliser Live Photos ?