How to re-start "SSDP Discovery Service"

  johnem 18:59 21 Aug 2007

I am having an annoying problem in that my Canon digital camera is not recognised by the Zoombrowser software. From various other forums I ahve gleaned the information to run "services.msc" and check if "SSDP Discovery Service" is set to automatic start. I have found that mine is set to disabled, possibly as a result of using Tune Up Utilities 2007, as I recall see and clicking on a security note about UNPnP.
When I try to set SSDP to automatic, I am shown a flag "Access denied".
I am signed in the system administrator as administrator.
Any suggestions as to how I can set "SSDP" to automatic, if only to help solve the camera problem?

  skidzy 19:10 21 Aug 2007

Are you trying to enable the service while the camera is connected ? if so disconnect the camera and try again.

Have you tried restarting the service via right clicking on the service and restart.

Sorry not a great deal of help,but can say mine is set to manual.

  johnem 19:18 21 Aug 2007

Hi skidzy,
Good thought, yes I was trying to alter the setting with the camera connected. Just tried it now without the camera, still displays "access denied."
I think I may need to contact Tune Up Utilities, to see if there is a way around this. I cannot use their "restore" feature as the system has just been re-installed using Acronis 10.
Did not want to go down the windows XP repair route if I could avoid it.

  skidzy 19:27 21 Aug 2007

You may need a reboot and try the service again.

Can you reload the camera software ? this may set the service back to manual enabling you to start and restart the service.

Again not a lot of help im afraid.

  johnem 19:31 21 Aug 2007

Thanks skidzy,
That was my first move, uninstalled and then re-booted. Installed, made the adjustments, re-booted et al. Ho hum. I suspect that however Tune Up has disabled UnPnP, it has put an access block in place. Possibly if I could use their restore I might have been able to remove the access block. Did not want to re-install XP yet again.

  skidzy 19:33 21 Aug 2007

I suppose you could check the bios and see if there is a setting to enable UnPnP.

  johnem 10:57 22 Aug 2007

Hi Skidzy,
Have been away from puter for a while, will have a look this evening. Any other ideas please.

  johnem 20:37 22 Aug 2007


  woodchip 20:57 22 Aug 2007

It may be showing a Flag, Because there are other Services that should be running

  woodchip 21:04 22 Aug 2007

Have you got UPnP Disabled in Services if so try enabling it the try SSDP.

running SSDP is a Risk in Security

  johnem 21:06 22 Aug 2007

Evening woodchip,
i have checked that the "Canon camera Access Library 8" is set to automatic, it is. I have also checked that "WIA(Windows Image Acquisition)" is set to automatic and it is. These items were mentioned in another forum referring to Zoombrowser. Any other suggestions please.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review

How to draw a mandala

iPhone X review

Musique en streaming : Spotify vs Deezer