How have I got read- only Word Files

  bpzoom 20:05 02 Dec 2014
Locked

Microsoft 7 Word 2010. I run a single computer at home with no other computers in the house. Over the years I have created and saved many Word files currently I am using WORD 2010. Sometimes when I go to edit a Word file it tells me it is "Read only". It will not save or even delete if I want it to do either, and I get the message "The file id still open in Word" and Try Again or Close. 1. Can anyone tell me how "Read Only" files have been created in Word as I have never knowingly done so. and 2 How do I remove the status "Read Only" if I want to edit and save it or even delete it? I have tried Help under Windows and a network is mentioned as being relevent which I know nothing about.

  northumbria61 22:17 02 Dec 2014

You should be able to right click on the file before opening it, select properties, under security tab - edit and change permissions - give yourself full control

  bpzoom 22:43 02 Dec 2014

OK Thank you. When I right clicked I got the permissions for the file name. In the box for group or user names there are 4 entries System Brian(brian-PC\brian) Home Users (brian-PC\home users) Administration (brian-pc\administration) I don't have a clue what each of these is or why there are so many. For each one I checked for the properties and only Home Users (brian-PC\home users) has the facility to alter permissions in the permissions box. The others are greyed out in their permission boxes. The setting for Home Users (brian-PC\home users) is allow full control. I still can't change the file which remains "created as a Read Only file". I am all at sea.

  robintheumpteenth 00:23 03 Dec 2014

Properties/Security Tab/Permissions can be a bit tricky. If it says full control, leave it for the moment.

Check that the Read-only box is cleared on the Properties/General Tab and not set. Apply.

Also the Read-only boxes for the folder your files are in. eg Documents/My Documents.

Read through these suggestions (some duplicates and some work for some users and not others)

click here

Read thread right to end of page.

-.-

A workaround is to 'Save As' documents to another similar filename.

eg ExampleDocument1 to ExampleDocument1.2

  bpzoom 14:03 03 Dec 2014

Thank you, most helpful. I will follow that through. Saving with a slightly different filename is a get around I agree.

  bpzoom 14:25 03 Dec 2014

I read down to the end as you suggested,and tried this one. So far it has worked on 2 files which were trapped in Read Only. Thank you for finding this out for me, I am most grateful.

Open Windows Explorer. In the upper left is a pull down menu that is labeled Organize. Click it and go down to Layout, select "Preview pane" to turn it off.

  robintheumpteenth 16:17 03 Dec 2014

Glad it worked.

  bpzoom 16:23 03 Dec 2014

Ha Ha, you might guess it worked on one file which I was able to alter and save, It has not worked with others. When I went to the top folder called Iceland containing many sub folders and files, I found that Read Only was set for that folder. I unset it and applied which resulted in a run through all the owned folders. The read only was unset. When I checked back on the folder properties, Read only was set again ! Back to square 1.

  bpzoom 16:31 03 Dec 2014

When I unset Read only for the lowest folder owning the file I am dealing with, I am able to delete or amend the Read Only file. When I go back to the folder properties, Read only is set again. If that pattern continues, I can live with it as not many of my files are smitten with he Read only curse.

  robintheumpteenth 18:22 03 Dec 2014

I checked some more. Seems like the Properties/General Read-only checkbox is a bit of a red herring.

You will have to get to grips with Properties/Security permissions.

I had problems when I first started playing with them in W7.

Usually I can do what I want these days, but it's trial and error sometimes. I always go in the Advanced settings and play there.

I often cheat when I hit problems. I'll take ownership of stuff I shouldn't, set full control for Everyone everywhere, even at root level. ('Everyone' can be created as a new User in permissions)

It's important to pay attention to the Inheritance checkboxes too and that you do have to wait a minute when you hit Apply so you are sure they are being propagated.

-.-

Bedtime reading....

click here

Good Luck.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Lightwell software lets you create mobile apps without using code

Best value Mac: Which is the best £1249 Mac to buy

Comment désactiver les programmes qui s'exécutent au démarrage de Windows 10 ?