How Do I format my 2gb SD card to full capacity?

  Dr Ben 00:02 18 Jul 2006
Locked

Hi everyone. I bought a 2 gb Dane elec SD card and now that I have formatted it, it appears to only have 1 gb capacity when I click on its properties. Has anyone else had such a problem, and if so, how do I format my card to its full 2 gb capacity?

Thanks

  sean-278262 00:05 18 Jul 2006

What OS are you using.

  skidzy 00:06 18 Jul 2006

To lose so much capacity sounds like a dodgey card to me.Have you tried to format the card in another device such as a camera ?

  Dr Ben 00:08 18 Jul 2006

Im not great with computers, but I have windows XP on my laptop, which I plugged the USB SD card reader into, is that what you mean?

  Dr Ben 00:09 18 Jul 2006

No, I havent tried to format it in a camera yet. Difficult though as I dont have a camera with an SD slot in it.

  sean-278262 00:12 18 Jul 2006

yes right click on the drive in my computer. Then click on format.

In the screen see what it says is the capacity of the drive. If it says it is 1gb then you didnt get a 2gb card and it is either wrongly labeled or has a problem. If it says 2gb format it to fat32 if it is for use in a camera or NTFS if you just store data on it. Dont adjust anything else as the preset settings other than NTFS and FAT setting.

A

  skidzy 00:12 18 Jul 2006

I was just thinking maybe xp could have rushed the format and created bad sectors,hence why i ask if you have another device to plug the card into,and format.

How many times have you formatted the card ?

  Dr Ben 00:15 18 Jul 2006

When I first used the card, which was about a month ago, it said there was 2 gb when I clicked on properties. It now says 1 gb (just a bit less), so it definately was a 2 gb to begin with. I have only tried formatting it about 2 times.

  skidzy 00:19 18 Jul 2006

And you have no data stored on the card at this time ?


I would suggest you save any data on the card if it exixts and format again,but it sounds like you have bad sectors on the card.

  Dr Ben 00:21 18 Jul 2006

I have no data on the card. I tried formatting it again andit still says there is only 1 gb capacity. I dont know what sectors are, and what the implications of bad ones means.

  skidzy 00:23 18 Jul 2006

Basically corrupted memory.
Just a thought,have you tried moving the security switch on the side of the sd card and format,if its locked ...you should not be allowed to format anyway...wild guess now if the card is not corrupted.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Best of the Grad Shows 2017: UAL Central Saint Martins

MacBook Pro 15-inch (2017) review

Comment connecter un MacBook à une TV ?