How do I enable a large hard drive?

  ? DP ? 18:47 14 Apr 2004

I am running XP Pro with SP1 installed.

I have a 200GB Maxtor hard drive but my system only recognises 127GB of it. Apparently this is the limit that XP can safely 'see' on a HDD. I went to the maxtor site and downloaded their 'big drive enabler' but when I try to run the prog. it tells me that my OS is not suitable.
Are there any other ways of forcing my system to recognise the full 200GB? I don't like being 73GB down!

  GANDALF <|:-)> 19:03 14 Apr 2004

Billy boy to the here


  byfordr 21:50 14 Apr 2004

click here

How I did it.


  ? DP ? 22:43 14 Apr 2004

yeah, I should mention that my primary master disk is an 80GB one (which is completely full) and the Maxtor 200GB drive is a primary slave, without an OS on it. In fact, it has nothing on it - I just want to use it to store data.

  temp003 09:26 15 Apr 2004

You need both the operating system and the BIOS to support >137GB hdds.

Check in BIOS what disk size it reports. If it's reporting less than the correct size, look in BIOS settings to see if there's an option to enable 48-bit LBA (not just LBA). If there is, enable it.

If your present BIOS does not support it, find out motherboard model number and see if there is a BIOS update which gives support to >137GB hdds, then flash the BIOS.

If not, either buy a PCI IDE adapter (get ATA-133 because that's sure to support your disk size) which is the better option, or use Maxtor's drive overlay software MaxBlast3 and the Big Drive Enabler.

If you use the latter option, make sure you have backup of the MaxBlast3 software (on CD or floppies) as you may need to reinstall it every time you repair or reinstall Windows. But it's free.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?