How do I enable DMA mode?

  Border View 15:30 24 Dec 2003
Locked

To try and get my Power DVD to work properly a system diagnostic is telling me To install the IDE or bus master driver that comes with your motherboard and enable the DMA mode for accessing your DVD-Rom. I'm sure that the IDE or bus master driver is installed (because I've used Power DVD in the past)

So, please, where do I go to enable the DMA mode.

Your help would be much appreciated.

  jonnytub 15:47 24 Dec 2003

this site should give you ample info on dma, enabling it and whether or not you actually need it for what you are trying to achieve, regards jonny click here

  Gongoozler 15:49 24 Dec 2003

Right click on "My Computer", select Properties, click on the "Device Manager" tab, find the drive you want to enable DMA for, right click and select "Properties", click the "Settings" tab and put a tick in the DMA box.

  Border View 15:54 24 Dec 2003

Thank you for responding.

After over 1200 visits to this web site I should have mentioned that I am running Windows 98SE and have a Samsung CD-RW/DVD combo.

I've been into Device manager and can't find any reference to DVD only CD-RW.

Am off to have a look at that site johnnytub.

Any more suggestions please.

  jonnytub 15:57 24 Dec 2003

is your dvd drive a combo dvd/cd-rw ?

  Quiller. 15:59 24 Dec 2003

Depends on your operating system;

for 9X, i.e. 98 M.E. go to device manager \ cdrom-dvd drives and click on the dvdrom. Pick the middle tab and tick the box for enable dma on this device. It will ask for a reboot.

For X\P and 2000. Go to device manager and click on the IDE ATA/ATAPI controllers. Pick which channel your dvdrom is on, either primary IDE or secondary IDE. Open this up and pick advanced settings. Then pick either device 0 or 1, master or slave. You will have a drop down box for this.Under transfer mode pick " DMA if available"

Probably want a reboot then. Hopefuly it should then come up with multi-word DMA2 for current transfer mode.

  jonnytub 16:03 24 Dec 2003

your computer will support dma mode if the check box is still ticked after reboot, it will not if the box is empty after reboot, regardless of os. just incase you go through the process a few times before realising as i stupidly did.

  Border View 16:18 24 Dec 2003

Thanks fellas. I got as far as putting a black spot in the DMA box but then got the message or words to the effect that enabling this device could have serious consequences for my hardware. Contact your Hardware Vendor. So I didnt enable it and will now send an e-mail to Evesham.

Many thanks for your help. Now that I've found out how to enable DMA, even though I dare not, I shall put a green tick for resolved.

A happy and healthy Christmas and New Year to you all.

  Quiller. 18:40 24 Dec 2003

It always says that when you tick the "enable dma" box.

Tick it and reboot, if dma is not available for the dvdrom, I doubt it, it will reboot with check box still un-checked.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?