How to change/check mtu size on Speedtouch 585 (v6)?

  ened 07:55 22 Oct 2011
Locked

Hi. I have changed my router to a Speedtouch and cannot find a way to check the mtu size.

There are many old threads which refer to using a command prompt and typing the following: telnet 192.168.1.254.

But when I do this I receive the following message: " 'telnet' is not recognised as an internal or external command, operable programme or batch file."

Help Please?

  gengiscant 08:10 22 Oct 2011

Here is a site that will help you find the correct settings, more information than you ever really wanted on your router. it really does give you all the information MTU, MSS, RWIN, etc. Analyzer

Once you have that you can use the CLI or the Web interface to change the settings in the SpeedTouch /

  gengiscant 08:12 22 Oct 2011

You could also use this: Tweak MTU

  ened 08:48 22 Oct 2011

gengiscant That link says it doesn't work for Vista. I have win7 (64 bit).

All I really want to do is check the mtu is correct according to my previous setting (on a Netgear).

I don't really want to be downloading anything else and I guess I was hoping somebody would tell me why the instruction (which must work because it is suggested all over the place)comes up with the above result.

I am not very good with DOS and feel I might have missed a trick.

  gengiscant 09:43 22 Oct 2011

To install the telnet client which is not installed by default. Go into Control Panel > Programs and features > Turn windows features on/off > choose 'Telnet client'

Configuration: MTU cannot be altered via the SpeedTouch's Web interface and must be done via the Command Line Interface.

You will first need to open a terminal or command prompt window.

Mac OS X: From Go choose Utilities and Terminal.

Windows 7: From the Start Menu choose type cmd and right click cmd.exe and click on run as administator.

At the prompt type

telnet 192.168.1.254

By default the username to access the SpeedTouch router is Administrator and the password is blank, ie. nothing. If you have changed these details at some point use your own username and password.

Enter Administrator as the username and press Return/Enter.

You will now see the following prompt:

{Administrator}=>:

Type the following lines of code after the prompt, pressing return/enter after each line. The mtu value used below is 1458, but you may use any value as you see appropriate up to 1500.

ip ifconfig intf=LocalNetwork mtu=1458 saveall

You may now close this window and the changes should take place immediately.

  ened 10:10 22 Oct 2011

Thanks for taking the trouble to write out those instructions gengiscant.

However I have followed those and receive the message I reported in my first post.

I have tried cd c:\ and then pasted the command. What ever I do it tells me the same thing.

I assume it is down to my lack of understanding of DOS, which is why I need a pointer or two.

  gengiscant 11:41 22 Oct 2011

Daft question I know,did you install telnet client? and it is easy to make mistakes if typing a command so just copy and paste from the instructions.Another read for you. Telnet

  ened 12:07 22 Oct 2011

gengiscant Not a daft question at all!

I misunderstood you. I'm off to install it now..........

...and it works now. Thanks for your help and sorry for being so stupid!

  gengiscant 12:12 22 Oct 2011

Hey,no problems.Let me know how you get on.

  ened 12:30 22 Oct 2011

Thanks.

Assuming it has worked I have changed? the mtu to 1432 which is the setting I had on my Netgear. This was the setting I got from AOL. I have no idea what the previous setting would have been or if it even needed changing.

But (I appreciate this is not a scientific test) this morning I have been getting 13mbps and now am only getting 11.

It might be other factors but I am now wondering if I did the right thing.

I really needed to know the default setting so that I can experiment.

Thanks once again for your help.

  gengiscant 12:48 22 Oct 2011

Have you run the analyzer I linked to? Of course you will get different download speeds at different times of the day due to contention ratio: Explanation

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?